New Install Puppet Agent Failing

**Hi I seem to have a small issue with the puppet agent deployed on a test host (V6.5.0) puppet agent -t fails with the below error, but puppet agent -t works fine on the foreman server and smart proxy

Warning: Error 500 on SERVER: Server Error: Could not load external node results for XXXX: (): Tried to load unspecified class: Time

Googling the issue has so far not provided a soultion

Puppet agent -t succeeds and downloads assigned puppet classes to host

**Foreman and Proxy versions: 1.22.0 **

Foreman and Proxy plugin versions:

Other relevant data:
Puppet agent config for client

basemodulepath = /etc/puppetlabs/code/environments/:/etc/puppetlabs/code/modules:/opt/puppetlabs/puppet/modules
certname = XXXX-HOSTCERT
codedir = /etc/puppetlabs/code
environmentpath = /etc/puppetlabs/code/environments
hiera_config = $confdir/hiera.yaml
hostprivkey = $privatekeydir/$certname.pem { mode = 640 }
logdir = /var/log/puppetlabs/puppet
pluginfactsource = puppet:///pluginfacts
pluginsource = puppet:///plugins
privatekeydir = $ssldir/private_keys { group = service }
reports = foreman
rundir = /var/run/puppetlabs
show_diff = false
ssldir = /etc/puppetlabs/puppet/ssl
vardir = /opt/puppetlabs/puppet/cache

classfile = $statedir/classes.txt
default_schedules = false
environment = production
listen = false
localconfig = $vardir/localconfig
masterport = 8140
noop = false
report = true
runinterval = 1800
splay = false
splaylimit = 1800
usecacheonfailure = true


Issue solved, basicly seems Foreman does not exactly support puppet 6, if anyone is experiencing the same issue a downgrade (server and client) to puppet 5 worked fine.

Are you using Katello by any chance? Bug #26763: Foreman/Katello node.rb Issue with Puppet 6 - Katello - Foreman is likely the issue you’re running into.