No permission to edit/change after Foreman Update 1.19 => 1.22


#1

Problem:

Hi Foreman Team,

We have encountered an issue after updating the Foreman from 1.19 to 1.22 we can’t change puppet classes or add users within the WebGUI and also receive no optical Feedback that something errors (instead, after applying a change we are jumped straight back into the first tab ‘Host’) … in the production.log there is just the following entry here as an example

2019-06-26T14:51:58 [W|app|5c8e1168] Not queueing Host::Managed: ["medium
Must belong to the operating system of the host"]
2019-06-26T14:51:58 [E|app|5c8e1168] Failed to save: Medium Muss zum
Betriebssystem des Host gehören
2019-06-26T14:51:58 [I|app|5c8e1168]   Rendering hosts/edit.html.erb
within layouts/application
2019-06-26T14:51:58 [I|app|5c8e1168]   Rendered hosts/_progress.html.erb
(0.3ms)
2019-06-26T14:51:58 [I|app|5c8e1168]   Rendered
hosts/puppet/_main_tab_fields.html.erb (11.5ms)

From the Line => 2019-06-26T14:51:58 [W|app|5c8e1168] Not queueing Host::Managed

We took a look inside the foreman database in the host table to find the following most hosts have a managed flag ‘false’ instead of ‘t’ but have also an entry with ‘Host::Managed’.

here also an excerpt

  id  |                     name                      |    last_compile     |     last_report     |         updated_at         |         created_at         |                        root_pass                        | architecture_id | operatingsystem_id | environment_id | ptable_id | medium_id | build | comment | disk |       installed_at        | model_id | hostgroup_id | owner_id | owner_type | enabled | puppet_ca_proxy_id | managed | use_image | image_file | uuid | compute_resource_id | puppet_proxy_id |                   certname                    | image_id | organization_id | location_id |     type      | otp | realm_id | compute_profile_id | provision_method |                        grub_pass                        | global_status |                lookup_value_matcher                |  pxe_loader   | initiated_at | build_errors 
------+-----------------------------------------------+---------------------+---------------------+----------------------------+----------------------------+---------------------------------------------------------+-----------------+--------------------+----------------+-----------+-----------+-------+---------+------+---------------------------+----------+--------------+----------+------------+---------+--------------------+---------+-----------+------------+------+---------------------+-----------------+-----------------------------------------------+----------+-----------------+-------------+---------------+-----+----------+--------------------+------------------+---------------------------------------------------------+---------------+----------------------------------------------------+---------------+--------------+--------------
  583 | dummy.host.com               | 2018-07-31 07:36:56 | 2019-06-26 13:17:26 | 2019-06-26 13:17:32.49115  | 2017-04-21 06:18:57.344097 |                                                         |               1 |                 99 |              1 |           |           | f     |         |      |                           |        1 |            5 |        5 | User       | t       |                  1 | f       |           |            |      |                     |               1 | dummy.host.com               |          |               2 |           1 | Host::Managed |     |          |                    |                  |                                                         |             0 | fqdn=dummy.host.com               | PXELinux BIOS |              | 

We ask kindly for help.

Expected outcome:
Update from 1.19 to 1.22 should not effect already created and newly added hosts

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
(for logs, surround with three back-ticks to get proper formatting, e.g.)

logs

#2

I attached the screenshots for my colleague, because he can not do so for not been active enough.

Screenshot2


#3

We’ve tried to changed on some Host back to ‘Host managed’ but even then sometimes the following error occurs.

Can not Save:
No PXELinux template was found for this host. Please make sure that at least one template is entered in your Debian 8.11 settings, or change the PXE loader

We create a new Screenshot to show the Issue.


#4

IMHO the bug is simple to describe: Foreman 1.22.0 complains for mandatory fields, even if they should not be considered like the managed host ones.

A workaround for this specific problem is to assign a media (e.g. “Debian Mirror”) to the operating system version (e.g. “Debian 8.11”).