No repositories available, but subscriptions are attached and valid

Problem: repolist: 0, but subscriptions are attached and valid.

Expected outcome: repolist with repositories.

Foreman and Proxy versions:

Foreman and Proxy plugin versions: Foreman 3.2.1 and Katello 4.4.1

Distribution and version:
RHEL 8.6

Other relevant data:


Katello server has valid RedHat Subcriptions and was working, subscriptions expired, then refreshed the manifest to update the renewed the subscriptions and since then have this issue.

[ yum.repos.d]# yum repolist
Updating Subscription Management repositories.
No repositories available
[ yum.repos.d]# subscription-manager identity
system identity: 54fdb370-33f8-4adf-8e4d-6cf6cf91c61c
org name: Default Organization
org ID: Default_Organization
environment name: Production/RH8_JULY-2022
[ yum.repos.d]# subscription-manager status
System Status Details
Overall Status: Current

System Purpose Status: Matched


Only RHEL6 servers are getting repositories, RHEL7 and RHEL8 servers are not getting repositories, this is happening all RHEL7 and RHEL8 servers.


Best regards,
Balaji Sankaran.


when the subscriptions in your manifest expire, all your clients lose all their “Katello Internal” subscriptions too.
Have you tried running subscription-manager attach --auto on your clients or checked if your clients can see any subscriptions (e.g. with subscription-manager list --available)?
I would expect your clients to currently have zero subscriptions consumed (“attached”), you can check that with subscription-manager list --consumed. If they have subscriptions consumed, try subscription-manager repos --list to check if they can see your repos and use subscription-manager repos --enable <reponame> to try and enable the repos.


Hello Areyus,

I already tried subscription-manager attach --auto it is subscribing fine.

[root@ ~]# subscription-manager attach --auto
All installed products are covered by valid entitlements. No need to update subscriptions at this time.
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status: Subscribed

For the command subscription-manager list --available the client-server is listing all the RedHat subscriptions.

For the command subscription-manager list --consumed the client-server show as consumed “1”…

Provides Management: No
Active: True
Quantity Used: 1
Service Type: L1-L3
Roles: Red Hat Enterprise Linux Server
Service Level: Premium
Usage: Production
Status Details: Subscription is current
Subscription Type: Instance Based
Starts: 07/19/2022
Ends: 07/19/2023
Entitlement Type: Physical

For the command subscription-manager repos --list below is the output…

[root@ ~]# subscription-manager repos --list
This system has no repositories available through subscriptions.

I tried all of the above already, still client-servers showing no repositories on RHEL7 and RHEL8, but only RHEL6 client-servers shows RHEL6 ELS repositories.

Best regards,
Balaji Sankaran.

Hm, this is odd. On the first glance, looks like everything is fine on the client-side.
Maybe something got messed up on the Katello end when the subscriptions expired? Have you checked if all the RedHat Repos are still enabled under “Content” → “Red Hat Repositories”? Do they sync properly?
If yes, you could try to re-publish/promote your Content View.
Just poking at things here though, I have not had this happen myself yet.

RedHat repos are still enabled and the repositories sync properly without any errors/issues.
I will try re-publish and update you.

Best regards,
Balaji Sankaran.

Thank you so much for the help!
That was it, had to publish a new version of content views and it resolved the issue.

Best regards,
Balaji Sankaran.


I ran into exactly the same problem with Red Hat Satellite 6.10. Thank you for sharing the solution to this strange problem.

You’re welcome, rvva.