No Repositories available. No packages marked for update

Greetings. I inherited a foreman/katello setup at my new job for patch management. I am suddenly unable to apply the discovered errata for my RHEL systems. I can see patches are available but I am unable to apply them with “yum update.” I receive “No packages marked for update”

Expected outcome:
Hosts should be able to download and install updates.

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Distribution and version:
Red Hat 7.9

Other relevant data:

I tried to remove and re-add the Red Hat repositories under Content>Red Hat Repositories. But I am getting “No repositories available” on the RedHat Enterprise Linux Server RPMs and other repos as well. I ran “yum clean all” and removed the content in “/var/cache/yum” on the hosts. I did notice when attempting to refresh the yum repos on a host, the RHEL7 repo only syncs 1 package and then fails. I realize these software version are old, but I would appreciate any help.

Hi @luciousd

Could give a little more information around your configuration?

Are you using any proxies?
What is your content view layout?

Do the product repositories have packages?


Thank you for the reply. I do not have any proxies. I don’t have any content view, just the Default Organization View. The product repositories are showing synced packages.

Could you include a screen shot of your content view(s) as well?

You might select the repository and do a complete sync since it looks for be in a warning state.

The content view is attached though it’s empty.

I attempted a sync earlier by selecting the repo and choosing “Sync Now.” Is that what you mean? I can try again.

I would suggest selecting the repo you want to sync then use the drop down on the upper right to go the advanced and select to do a complete sync.

Are for the content views, these are what the systems normally use to get these package content.

Could you attach a screen shot of a content hosts detail page?

Yes! The complete sync has got me closer! The repos refresh but now I’m getting a 404 error on each package when I attempt to apply updates. Thank you again. I’m researching this error now.

[Errno 14] HTTPS Error 404 - Not Found
Trying other mirror

I added http_caching=packages to /etc/yum.conf on one of the hosts and it was able to download packages. But then I tried some other hosts without making changes and they were able to download packages. I think all is well, maybe I just needed to wait a while?

Thank you again so much, I think I’ll be ready for upcoming patch day.

1 Like