No route to host, foreman web-gui

I get no route to host when trying to connect to foreman server web gui from remote.
Expected outcome:

Foreman and Proxy versions:
Foreman and Proxy plugin versions:

Distribution and version:
RHEL 8.9
Other relevant data:
Im not able to connect to the foreman web server, getting no route to host. Im wondering if there could be something in the webserver config as the server had three different NICs (only one configured). Ive since disabled two of them, keeping only the one configured with ip.

Sorry for the redaction on the picture, but it shows tcpdump running on the foreman server, 1 packet coming in from the IP which i ran telnet from. Below i run telnet towards foreman server, it resolves the hostname to the correct IP then gives no route to host.
I checked the default route on both servers and this is correct, however foreman server is behind firewall. I was told by networking that this is opened, although i suspect it might not be…

Im not so familiar with web services tho, so it could be at fault as well i guess. I looked at the configs i could find, but i found no block lists or similar, i also see it listening on 80 and 443 and there are no interfaces specified anywhere that i could find.
No log messages in httpd logs related to the connection attempt.

Please don’t post screenshots. They are very hard to read. Copy the text into a blockquote…

If you are checking with tcpdump always remember to dump ICMP packages as well. I guess, if you did, you would see your foreman server sending an unreachable ICMP back as you seem to capture the SYN from the client.

That would mean the firewall on your foreman server is blocking port 443.

Yeah sorry about the screenshot, i will keep that in mind.
And yeah, firewall it was… Ive become so complacent that i didnt think to check if this was enabled by default as it usually isnt in the distros i mostly work with.
Thanks for the tip regarding tcpdump, i never thought of that.