On the network gateway and the HTTP Proxy, enable TCP for the following host names

I am unsure on how to enable tcp for certain hostname for my satellite install which tcp 443 needs to be enabled for hostname subscription.rhsm.redhat.com and cdn.redhat.com. i am following this.
Installing Foreman 3.3 Server with Katello 4.5 Plugin on RHEL/CentOS (theforeman.org) on step 3.1

This should be able to allow me to sync our repositories once this has been enabled.

You would have to know that, your network layout and the proxies/security/firewall you have in your network. To sync the foreman server needs to be able to access the repository to sync in the internet. If your firewall filters outgoing traffic then you need to enable those outgoing connections needed to sync the repository. If you need redhat repositories it’s those hosts listed in the docs you have linked.

But you or your network/firewall admin must know how to do that exactly.

In the end your foreman server must be able to connect to the necessary servers in the internet, e.g. try

$ curl -k https://cdn.redhat.com/
<TITLE>Access Denied</TITLE>
<H1>Access Denied</H1>
$ curl -k  https://subscription.rhsm.redhat.com/
<head><title>404 Not Found</title></head>
<center><h1>404 Not Found</h1></center>

If you don’t see HTML as response there but instead timeouts or failed connections, something in your network is blocking that traffic.