Opensuse 15.1 provisioning

Foreman Version: 1.22

Hi - I am trying to provision a bare metal with OpenSuse 15.1. I am getting installation media error like in the attached pic.

rescanning devices
url mount: trying (path = opensuse/leap/15/1)
(Intel 1350 Gigabit Network Connection)
interface setup: eth1
ifcfg_write: device = eth1, ifcfg = (null)
creating ifcfg-eth1:
adjusting /etc/sysconfig/network.dhcp:
eth1: network config created
sending DHCP request to eth1…
no/incomplete answer.
eth1 network setup failed
device not found (err = 1): eth1
repository: not found
no openSUSE Leap 15.1 repository found

Please help!!

Can I get some help on this, please

Please describe all steps you have performed in order to verify that your installation medium is available to the provisioned node.

please see the attached OS settings.

under installation media, i have the opensuse mirror pointing to$version/repo/oss

OS template as

Well, what I see is a system which is having hard time to access a HTTP URL. Again, describe all steps you have performed in order to verify that your installation medium is available to the provisioned node. Like connecting to the machine via SSH or console and performing some commands (nslookup, ping, telnet, curl/wget)…

what is the pxe loader option i should use. currently i m using PXELINUX BIOS

This is irrelevant for your problem. As I said, investigate the host which shows you the error, physically you need to be at its console or ssh terminal.

Hi Izap,

I still stuck with opensuse installation. I am able to ping the installation media and able to wget from foremen server. It is actually failing at n/w interface configuration point at kernal level installation. is there a way to increase the dhcp timeout? also can you point out to documentation that lists step by step for opensuse provisioning. Please help and it will be greatly appreciable.


Is DNS also correct?

I don’t use Suse so I can’t help, you better try Suse community and then modify your template. Ideally, send us a patch into community-templates repo, add a DHCP timeout parameter or something like that if you resolve your issue.

I can confirm that slow DHCP servers are very often culprit of a problem.

This issue is finally resolved by adding ifcfg=eth0=dhcp,DHCLIENT_CLIENT_ID=<%=@host.mac %> in AutoYaST default PXELinux provsioning template.

for reference:

Looks like BOOTIF option generated by PXELinux is missing, IPAPPEND 2 will do that. I changed iPXE template as well. This should help without the need of the ifcfg argument:

@narayan if you can confirm that PR works, then we can merge the fix upstream. Most of us don’t have a SLES environment to confirm.

I tried the changes suggested by Izap (below), it didnt helped. FYI, we are using version foreman 1.22.

After further research, my patch solves a different thing. In your case, your DHCP server (what’s that by the way) have some problems with parsing the default DHCP client ID which is sent by OS. So you set it to MAC address to get around it. But I believe this will work out of box for most users, it’s some misconfiguration on your server probably. Is this Ethernet or Infiniband?

Hi @lzap

I had the issue and I can confirm your patches actually fixed it for me. narayan’s patch also worked, but I think yours might be a bit cleaner? Thank you very much…

If we could get that patch re-submitted and integrated that would be awesome. We use openSUSE and SLES and being able to deploy them easily would be huge.

SLES 15 (GA) doesn’t seem to deploy properly, but I might have bad media… will try again once I get my hands on SP1 or SP2.

SLES 15 SP2 is also no go. I’ll open a new thread about it.

We have closed the PR as there was no response:

Feel free to open a new one.

I create ifcfg just like that
ifconfig = “ifcfg=#{@host.primary_interface.identifier}=dhcp,DHCLIENT_CLIENT_ID=#{@host.primary_interface.mac}”
and it worked perfect.