Overriding iPXE local boot

We have configured a alternate default local boot menu for iPXE and have updated settings accordingly to point to this file. The host(s) in question do not have a local_boot_iPXE parameter defined. When rendering the local boot iPXE it still renders the stock/provided template and not the one we have defined.

Is there something else that needs to be updated for this change to take effect?

Currently running 1.22-RC1

From the logs I can see the update call being made to change the local_boot_iPXE setting.

Looks like a bug, in the iPXE code we have: @host.local_boot_template_name(:ipxe) so try lowercase. If you confirm I think I am going to add a patch that will always try normal case and then all lower case. It actually looks beter all lowercase. But try this first.

Edit: To be more clear, try this host param: local_boot_ipxe

Actually here you are:

Manually applied the patches and I am now seeing the boot menu I expected. Thanks for the quick assist. I was hoping to dig into it more this week and see if I could track it down.