Package conflict with Foreman 3.10 on RHEL 9

When best is enabled in DNF (I think the default for RHEL9), it will always try to get the latest version of any package and fail if another package is constraining a dependency to an older version of the package.

foreman-redis requires rubygem-redis 4.5 but 4.6 is available from the el9 repositories, so dnf update fails unless exclusions are put in place. Our ops team don’t want to modify the DNF settings.

 Problem: cannot install both rubygem-redis-4.6.0-1.el9.noarch from production-epel9-everything and rubygem-redis-4.5.1-1.el9.noarch from @System
  - package foreman-redis-3.10.0-1.el9.noarch from @System requires (rubygem(redis) >= 4.5.0 with rubygem(redis) < 4.6.0), but none of the providers can be installed
  - cannot install the best update candidate for package rubygem-redis-4.5.1-1.el9.noarch
  - problem with installed package foreman-redis-3.10.0-1.el9.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Expected outcome:
Foreman 3.10 is compatible with RHEL9 system packages. Perhaps if it can be confirmed compatible with rubygem-redis 4.6 the constraint could be loosened?

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

1 Like

EPEL is not supported. You have to remove the epel repository and all packages installed from epel. See installation docs…