Passenger Problem provisioning hosts Foreman 1.14.3

The symptom of the problem I am having is that the http server for
passenger is not wanting to start on port 80.

[Thu Apr 06 11:04:11.913879 2017] [core:notice] [pid 140387] AH00094:
Command line: '/usr/sbin/httpd -D FOREGROUND'
initialize': Connection refused - connect(2) (Errno::ECONNREFUSED) from /usr/share/gems/gems/passenger-4.0.18/helper-scripts/prespawn:105:innew'
connect' from /usr/share/gems/gems/passenger-4.0.18/helper-scripts/prespawn:86:insocket'
head_request&#39; from /usr/share/gems/gems/passenger-4.0.18/helper-scripts/prespawn:145:in<main>'
initialize&#39;: Connection refused - connect(2) (Errno::ECONNREFUSED) from /usr/share/gems/gems/passenger-4.0.18/helper-scripts/prespawn:105:innew'
connect&#39; from /usr/share/gems/gems/passenger-4.0.18/helper-scripts/prespawn:86:insocket'
head_request&#39; from /usr/share/gems/gems/passenger-4.0.18/helper-scripts/prespawn:145:in<main>'
[ 2017-04-06 11:04:15.1163 140411/7f8bc9597700 Pool2/Spawner.h:738 ]: [App
140451 stdout]
[ 2017-04-06 11:04:24.8289 140411/7f8bc9597700 Pool2/SmartSpawner.h:301 ]:
Preloader for /usr/share/foreman started on PID 140451, listening on

Now I thought maybe it was related to a bug discussion I saw about SELinux
and the epel vs foreman ruby. However I had long since switched to
permissive in selinux.


SELinux status: enabled
SELinuxfs mount: /sys/fs/selinux
SELinux root directory: /etc/selinux
Loaded policy name: targeted
Current mode: permissive
Mode from config file: permissive
Policy MLS status: enabled
Policy deny_unknown status: allowed
Max kernel policy version: 28

I did downgrade passenger, this eliminated this message in the httpd log.

App 127275 stdout:
App 127275 stderr: --> passenger_native_support was compiled for Ruby API
version 2.0.0, but you're currently running a Ruby interpreter with API
version 2.2.0.
App 127275 stderr: Refusing to load existing passenger_native_support.
App 127275 stderr: --> No found for current
Ruby interpreter.
App 127275 stderr: This library provides various optimized routines
that make
App 127275 stderr: Phusion Passenger faster. Please run 'sudo yum
install passenger-devel-4.0.53'
App 127275 stderr: so that Phusion Passenger can compile one on the
next run.
App 127275 stderr: --> Continuing without

However I still get the socket error.

rpm -qa|grep passenger


SSL, ie the main web server for the foreman web interface works fine so I
am not sure why the issue with the httpd server.


I always have to keep digging. :slight_smile:

So, and I am not sure why, the file was edited last August, but in
/etc/httpd/conf/httpd.conf there was

#Listen 80

I changed this to

Listen 80

and suddenly it all works again, apache listens to port 80 and the nodes
can talk to passenger for that first little tickle on port 80.

I mean it makes sense, but how or what changed to remove that entry is