Permission denied error when executing ansible playbook

Hi i have installed foreman on centos7.5 and i have set up integration with ansible.

When i run an ansible playbook role i am getting the following error, I am unable to understand why i am getting permission denied error, pls suggest me how to troubleshoot
I also tried to place certificates in foreman directory.

ubuntu@foreman:~/infrastructure$ ansible-playbook -i production/on_prem ~/terraform_role.yml
plugin foreman_callback.pyc: SSL verification of disabled

PLAY ***************************************************************************

TASK [setup] *******************************************************************
 [WARNING]: Error when using <bound method CallbackModule.v2_runner_on_ok of
</home/ubuntu/.ansible/plugins/callback_plugins/foreman_callback.CallbackModule object at 0x7fa9388ca1d0>>: [Errno 13] Permission denied

ok: [localhost]

i have passed these values into the

FOREMAN_URL = os.getenv('FOREMAN_URL', "")
# Substitute by a real SSL certificate and key if your Foreman uses HTTPS
FOREMAN_SSL_CERT = (os.getenv('FOREMAN_SSL_CERT', "/etc/puppetlabs/puppet/ssl/certs/"),
                    os.getenv('FOREMAN_SSL_KEY', "/etc/puppetlabs/puppet/ssl/private_keys/"))