Problem with CV after update

After updating foreman from 1.24 to 2.0 to 2.1.4 i tried to publish a new Version of a content view.
This shows the following error:
INSERT has more target columns than expressions

ActiveRecord::StatementInvalid: PG::SyntaxError: Error: INSERT has more target columns than expressions
LINE 1: …“erratum_pulp3_href”,“repository_id”,“created_at”,"updated_a…
Expected outcome:
successful publish of cv
Foreman and Proxy versions:
Foreman and Proxy plugin versions:
Katello 3.16.2
Distribution and version:
CentOS 7
Other relevant data:
During the Updates postgresl also seems to have been updated to rh-postgresql12 packages.

Hmm could you share me the stack trace from /var/log/foreman/production.log or may be even the foreman-debug ?


i have uploaded the part of the production log which shows the output when pressing the resume button in the failed task.
hope thats ok.
production.log (38.2 KB)

where can i find the foreman-debug information ?


I think we have enough information here. Trying to reproduce it on my dev workstation will ask if I need more. Do you know what repository types does your content view have? Wonder if it has extra files in its repodata directory

The CV i’m talking about is a Composite CV. It consists of 11 CV’s with 1 to 6 Repositories.
All Repo’s have RPM’s in them. At least 1 Repo is not synced from outside but handled manually.
is that the information you were looking for ?


any idea what could cause this issue ?
is it possible, that there is a problem with the pulp packages ?
i think they have been updated too during the updates of foreman.



i have solved the problem by going back to a vmware snapshot i took before upgrading to 2.0.
Version 1.2.4 from this snapshot worked fine. Then i upgraded to 2.0 according to the Documentation.
This also went fine and my foreman is now on 2.0.3 and running.
During the update to 2.0.3 i found a mention of a required pulp2->3 migration, which i probably didn’t do the last time.

Foreman :: Plugin Manuals -> Pulp3 Migration.

Could updating from 2.0.3 -> 2.1.4 without migrating pulp to version 3 lead to the problems i described in this issue ?

Kind Regards