Problem with the repo's GPG?

Problem:

Once I try to apt update, I am getting this error:

OK:1 http://security.debian.org/debian-security buster/updates InRelease
OK:2 http://deb.debian.org/debian buster InRelease                                             
OK:3 http://deb.debian.org/debian buster-updates InRelease                                     
Holen:4 http://deb.theforeman.org buster InRelease [50,1 kB]                                      
Holen:5 http://deb.theforeman.org plugins InRelease [50,0 kB]                                            
OK:6 http://apt.puppetlabs.com buster InRelease                                                            
Fehl:4 http://deb.theforeman.org buster InRelease                        
  Die folgenden Signaturen waren ung├╝ltig: EXPKEYSIG 6F8600B9563278F6 Foreman Automatic Signing Key (2016) <packages@theforeman.org> Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 0BDDA991FD7AAC8A
Fehl:5 http://deb.theforeman.org plugins InRelease
  Die folgenden Signaturen waren ung├╝ltig: EXPKEYSIG 6F8600B9563278F6 Foreman Automatic Signing Key (2016) <packages@theforeman.org> Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 0BDDA991FD7AAC8A
OK:7 https://packagecloud.io/sensu/stable/debian buster InRelease
Es wurden 100 kB in 1 s geholt (68,3 kB/s).
Paketlisten werden gelesen... Fertig
Abh├Ąngigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
W: W├Ąhrend der ├ťberpr├╝fung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: http://deb.theforeman.org buster InRelease: Die folgenden Signaturen waren ung├╝ltig: EXPKEYSIG 6F8600B9563278F6 Foreman Automatic Signing Key (2016) <packages@theforeman.org> Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 0BDDA991FD7AAC8A
W: W├Ąhrend der ├ťberpr├╝fung der Signatur trat ein Fehler auf. Das Depot wurde nicht aktualisiert und die vorherigen Indexdateien werden verwendet. GPG-Fehler: http://deb.theforeman.org plugins InRelease: Die folgenden Signaturen waren ung├╝ltig: EXPKEYSIG 6F8600B9563278F6 Foreman Automatic Signing Key (2016) <packages@theforeman.org> Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 0BDDA991FD7AAC8A
W: Fehlschlag beim Holen von http://deb.theforeman.org/dists/buster/InRelease Die folgenden Signaturen waren ung├╝ltig: EXPKEYSIG 6F8600B9563278F6 Foreman Automatic Signing Key (2016) <packages@theforeman.org> Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 0BDDA991FD7AAC8A
W: Fehlschlag beim Holen von http://deb.theforeman.org/dists/plugins/InRelease Die folgenden Signaturen waren ung├╝ltig: EXPKEYSIG 6F8600B9563278F6 Foreman Automatic Signing Key (2016) <packages@theforeman.org> Die folgenden Signaturen konnten nicht ├╝berpr├╝ft werden, weil ihr ├Âffentlicher Schl├╝ssel nicht verf├╝gbar ist: NO_PUBKEY 0BDDA991FD7AAC8A
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

Distribution and version:

Debian Buster

WeÔÇÖve been signing with a new (2021) key since a while: https://www.theforeman.org/static/keys/5B7C3E5A735BCB4D615829DC0BDDA991FD7AAC8A.pub

Seems you donÔÇÖt have it imported.

ItÔÇÖs also part of the keyring we publish at https://deb.theforeman.org/foreman.asc

See also the release notes for 3.0 where we started to use that key: Foreman :: Manual

1 Like

Yep, did not see that. Thanks, adding the new key worked fine.