Problem with unattended PXE Install


#1

Problem:
Can’t change url Parameter in Kickstart File
Changing Unattended URL in Administer->Settings->Parameter-Provisioning has no effect
Expected outcome:
beeing able to change the url parameter in kickstart file from hostname to ip
Foreman and Proxy versions:
1.20.2
Foreman and Proxy plugin versions:
katello 3.10.0
Other relevant data:
[e.g. logs from Foreman and/or the Proxy, modified templates, commands issued, etc]
(for logs, surround with three back-ticks to get proper formatting, e.g.)

logs

#2

Have you exited build and re-entered build mode for an existing host? Changing the setting will not schedule redeplyoment of PXE files.


#3

Hi,

changing the Parameter in the Settings doesn’t have any effect anywhere.
i even created new hosts, which still have in their kickstart file the setting as original:

install

url --url http:///pulp/repos//Library/Testing/custom/CentOS_7/CentOS_7/

i need to replace the FQDN in this URL by an IP Address.
What is supposed to happen when the Parameter “unattended Url” in the Settings is changed ?
In the meantime the system has been updated to
Foreman 1.21.3
Katello 3.11.1

Still the same behaviour

Regards
Frank


#4

Isn’t the url path dictated by the media chosen for the relevant OS ? I don’t think the unattended url is relevant in this scenario…

HTH
FM


#5

Yeah, I haven’t realized you have katello installed. When using katello plugin, unattended_url is actually not relevant and the hostname is actually Content Source smart proxy.


#6

I’m only interested in changing the FQDN in the URL Parameter to an IP Address.
Is this possible and if yes, how ?

Regards
Frank


#7

Not possible, Content Source defines this when Katello is installed and that is FQDN because of X509 certificates bound to it.