Promox issue with creating VM after 3.10 upgrade

Problem:
Same issue as in this forum post, Creating host failed
Basically you get a bad request.

Expected([200]) <=> Actual(400 Bad Request) excon.error.response :body => "{\"errors\":{\"arch\":\"value 'amd64' does not have a value in the enumeration 'x86_64, aarch64'\",\"ostype\":\"value 'debian' does not have a value in the enumeration 'other, wxp, w2k, w2k3, w2k8, wvista, win7, win8, win10, win11, l24, l26, solaris'\"},\"data\":null}" :cookies => [ ] :headers => { "Cache-Control" => "max-age=0" "Connection" => "close" "Content-Length" => "256" "Content-Type" => "application/json;charset=UTF-8" "Date" => "Tue, 11 Jun 2024 14:43:25 GMT" "Expires" => "Tue, 11 Jun 2024 14:43:25 GMT" "Pragma" => "no-cache" "Server" => "pve-api-daemon/3.0" } :host => "nnj2-pve2.walleyetrading.net" :local_address => "10.200.56.175" :local_port => 57964 :method => "POST" :omit_default_port => false :path => "/api2/json/nodes/nnj2-pve2-1/qemu" :port => 8006 :query => nil :reason_phrase => "Parameter verification failed." :remote_ip => "10.200.24.62" :scheme => "https" :status => 400 :status_line => "HTTP/1.1 400 Parameter verification failed.\r\n"

What is happening is the “OS” section is getting more info put into it in the web form than is supposed to be and is sending more info it should/setting different values than is expected for fog proxmox config.

Expected outcome:
VM Should be created

Foreman and Proxy versions:
3.10.0

Foreman and Proxy plugin versions:
rubygem-foreman_fog_proxmox-0.15.0-1.fm3_9.el8.noarch

Distribution and version:
RHEL 8.8
Other relevant data:
This is the extra information showing up in “Advanced” in the “Virtual Machine” tab in creating a host.

Oh, more info, it’s this pane showing up that shouldn’t.

<div id="container_advanced_options">

That should only show up if you’re creating a container.

And I found a work around. If you reset the value of virtual machine type, change it to LXC and than back to KVM/Qemu it works.

Basically it looks like the default value of KVM/Qemu isn’t being actually set and processed by the javascript on the backend, so, it’s displaying the options for both KVM and LXC instead of just the one listed.

Is there a particular setting you did which threw the error or general host creation had this issue?

General host creation made it. The tab for “Virtual Machine” shows all the options for both a VM and LXC configuration.

Looks like Javascript is not working for you as I couldn’t reproduce the error. The selection of VM type is done in javascript as the first step. Can you try to use different browser and/or clearing cache and disabling cache?

I’ve cleared the cache, tried incognito mode, tried in both Chrome and Edge. Tried it on 3 different computers of mine. Other users in my company are having the issue on their browsers as well.

Also tried a brand new install of Firefox (never installed on this computer) and it occurs there as well.

Is there anything in the browser console when you load the page initially?

No errors that I can tell in the console. I know I’m not the only one as there was another post of the issue, but there was no followup.

Maybe 3.11 will magically fix it :slight_smile: