Pulp command to generate sqlite-metadata giving error message


  • Recently transitioned hosts to subscribe to Foreman for repositories
  • the /var/cache/yum directory is filling up on many of our hosts
    • Think it is likely that this issue is caused by the issue described here.
  • The steps at above link appear to be for an older version of the pulp-cli, put in the newer equivalent command and receive the below error message
# pulp rpm repository update --name <redacted-repository-id> --sqlite-metadata
Error: Call aborted due to safe mode

Expected outcome:

  • pulp rpm repository update --name --sqlite-metadata runs without error
  • Only .sqlite files are created and stored on host

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

  • katello-

Distribution and version:
Centos Stream 8

Other relevant data:

  • Manually changed sqlite_metadata field in rpm_rpmrepository table in pulpcore database to 1; this increased cpu usage but two files (.xml and .sqlite) still appear to be generated

Hi @lkraft ,

You just need the --force flag to work around the safe mode. So:

pulp --force rpm repository update --name <redacted-repository-id> --sqlite-metadata

Many thanks Ian! So glad it’s a simple solution. Out of curiousity, do you know why there’s an option to use the command without the --force flag if it is required? Is there a way to disable safe mode?