Puppet 6 Supported in Foreman 1.22?


#1

Greetings,
I just updated to foreman 1.22 and noticed in the release notes that puppetca for puppet 6 now works with foreman1.22. Does that mean puppet 6 is now supported?

Thank you


#2

Yes, it is supported. The installer is updated to use the correct configurations but I don’t think we’ve updated the manual instructions yet to migrate. We have configuration file migrations in the proxy, but I don’t know how well we’ve tested those. Our automation mostly relies on the installer.


#3

is there an upgrade process? from 1.2.1 to 1.2.2 for Puppet 6? any documentation would be great.


#4

Found this for Puppet 4->5, are we to expect something of a similar format? Upgrading from Puppet 4 to 5 - Foreman


#5

I haven’t tested it yet, but I would expect the same reset-parameters and no special handling like the reinstall.
If someone is willing to try, the Upgrading guide is a wiki page, so everyone can create and afterwards extend it.


#6

The upgrade should be similar, but I actually made an effort to make it easier. Refactor #25839: Avoid storing puppetserver version related parameters in the answer file - Installer - Foreman (part of 1.21.0) was intended to automatically do the upgrade depending on the installed Puppet version, but I must admit I haven’t done the full job of documenting this as well. The intended support level should be that you just install the Puppet 6 packages, rerun the installer and it should update configs. If this doesn’t work, it’s a bug we should address.



#7

this is what i came up with it. The upgrade went successfully. I upgraded the Foreman first to 1.22 just following the upgrade guide.

For the puppet i used the following steps and upgraded successfully. I am not sure if they are all required but i tried twice and the following commands worked.

Puppet 6 Upgrade:
#Remove existing Puppet 5 server
yum remove puppetserver

Remove Puppet 5 repo channel

yum remove puppet5-release-5.0.0-6.el7.noarch
#Install Puppet 6 Repo channel
rpm -Uvh http://yum.puppetlabs.com/puppet6/puppet-release-el-7.noarch.rpm

Install Puppet server 6.4

yum install puppetserver
#Update Puppet Agent
yum update puppet-agent
#Resinstall Puppet agent aoth
yum reinstall puppet-agent-oauth
#Run Foreman installer
foreman-installer --noop --dont-save-answers --verbose
foreman-installer
#Reset puppet proxy etc in foreman
foreman-installer --reset-puppet-server-jvm-extra-args --reset-puppet-server-puppetserver-version --reset-puppet-server-puppetserver-metrics --reset-puppet-server-puppetserver-experimental
#Restart Web service then test Foreman from Web console
service httpd restart
#Optional update the system
yum update
reboot


#8

#Before
[root@myserver ~]# yum list installed | grep puppet
puppet-agent.x86_64 5.5.13-1.el7 @puppet5
puppet-agent-oauth.noarch 0.5.1-3.el7 @foreman
puppet-bolt.x86_64 1.17.0-1.el7 @puppet5
puppet5-release.noarch 5.0.0-6.el7 @puppet5
puppetserver.noarch 5.3.8-1.el7 @puppet5

#After
[root@myserver ~]# yum list installed | grep puppet
puppet-agent.x86_64 6.5.0-1.el7 @puppet
puppet-agent-oauth.noarch 0.5.1-3.el7 @foreman
puppet-bolt.x86_64 1.23.0-1.el7 @puppet
puppet-release.noarch 1.0.0-7.el7 @puppet
puppetserver.noarch 6.4.0-1.el7 @puppet