Puppet client environment is being ignored from foreman settings

I was not aware that you could still maintain site.pp when using foreman. Foreman is an ENC so it should determine the classes assigned and environments.
Do you have puppet setup to use foreman as an ENC?

Did you specify in your client's puppet.conf file which environment it belongs too?


Corey Osman

Green IT and Data Center Automation Specialist

··· On Aug 16, 2012, at 10:30 AM, Yaniv Fine wrote:

Hi experts .
i am runnig foreman 1
puppetmaster 2.7.18
i have setup a test client machine .
on foreman i have configured the new client to be part of the development environment .
on the client i have setup that it will run the following from site.pp to debug information .
notify { “environment”:
message => $environment

when i run on the client .
puppet agent --test --debug --verbose

i get "Notify[environment]/message: defined ‘message’ as ‘production’"
allthought on foreman this client is setup as "development"
when i add the
environment = development on the client /etc/puppet.puppet.conf
the client get “Notify[environment]/message: defined ‘message’ as ‘development’” which is ok .

BTW in foreman => settings
i have default_puppet_environment = testing
which is beeing ignored via the client .

is this normal that i need to override the foreman client setting . with a "environment = development on the client /etc/puppet.puppet.conf "

You received this message because you are subscribed to the Google Groups “Foreman users” group.
To view this discussion on the web visit https://groups.google.com/d/msg/foreman-users/-/5fHwjmavzHUJ.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/foreman-users?hl=en.