PuppetCA foreman proxy disabled due to conflict with autosign

Puppetca is being disabled in the foreman proxy due to conflict with autosign setting.

Expected outcome:
Puppetca should work as it did in version 1.17.

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Other relevant data:
I am using the latest version of theforeman puppet module for managing the puppet proxy, puppet, and the version server. The puppetca worked without issue in version 1.17. I upgraded to 1.18 but did not check if the puppetca worked because I immediately upgraded to 1.19.

Here is the error from the logs

Disabling all modules in the group ['puppetca_hostname_whitelisting', 'puppetca'] due to a failure in one of them: Provider 'puppetca_hostname_whitelisting' settings conflict with the main plugin's settings: [:autosignfile]

grep of autosign

grep -r autosign *
settings.d/puppetca_hostname_whitelisting.yml::autosignfile: "/etc/puppetlabs/puppet/autosign.conf"
settings.d/puppetca.yml::autosignfile: "/etc/puppetlabs/puppet/autosign.conf"
settings.d.old/puppetca.yml.dpkg-dist:#:autosignfile: /etc/puppet/autosign.conf
settings.d.old/puppetca.yml::autosignfile: /etc/puppetlabs/puppet/autosign.conf

Any ideas?

I upgraded to the latest foreman_proxy puppet module (8.0.2) and the error has been fixed. Thank you!