Push_facts.rb failing at interface to foreman

When push_facts.rb sends it's POST, the foreman server responds with an
error. FYI, Foreman 1.1 w. local puppet 2.7.19 & remote Puppet is 3.0.1
With ruby http.debug turned on I get the following

<- "POST /fact_values/create?format=yml HTTP/1.1\r\nContent-Type:
application/x-www-form-urlencoded\r\nHost: 10.21.12.112\r\nAccept:
/\r\nConnection: close\r\nContent-Length: 4654\r\n\r\n"

-> "HTTP/1.1 403 Forbidden\r\n"
-> "Date: Wed, 13 Mar 2013 23:21:55 GMT\r\n"
-> "Server: Apache/2.2.15 (CentOS)\r\n"
-> "X-Powered-By: Phusion Passenger (mod_rails/mod_rack) 3.0.17\r\n"
-> "Cache-Control: no-cache\r\n"
-> "X-Runtime: 0.199479\r\n"
-> "X-UA-Compatible: IE=Edge,chrome=1\r\n"
-> "Set-Cookie: _session_id=6a1f5ecc8db4f45894fca16175c1adca; path=/;
HttpOnly\r\n"
-> "Location: https://10.21.12.112/users/login\r\n"
-> "Status: 403\r\n"
-> "Content-Length: 1\r\n"
-> "Connection: close\r\n"
-> "Content-Type: text/plain; charset=utf-8\r\n"

Check Foreman's log file at /var/log/foreman/production.log and it
should say why the request was refused.

··· On 13/03/13 23:36, Larry Fast wrote: > When push_facts.rb sends it's POST, the foreman server responds with an > error. FYI, Foreman 1.1 w. local puppet 2.7.19 & remote Puppet is > 3.0.1 With ruby http.debug turned on I get the following > > <- "POST /fact_values/create?format=yml HTTP/1.1\r\nContent-Type: > application/x-www-form-urlencoded\r\nHost: 10.21.12.112\r\nAccept: > */*\r\nConnection: close\r\nContent-Length: 4654\r\n\r\n" > > -> "HTTP/1.1 403 Forbidden\r\n"


Dominic Cleal
Red Hat Engineering

> When push_facts.rb sends it's POST, the foreman server responds with an
> error. FYI, Foreman 1.1 w. local puppet 2.7.19 & remote Puppet is
> 3.0.1 With ruby http.debug turned on I get the following
>
> <- "POST /fact_values/create?format=yml HTTP/1.1\r\nContent-Type:
> application/x-www-form-urlencoded\r\nHost: 10.21.12.112\r\nAccept:
> /\r\nConnection: close\r\nContent-Length: 4654\r\n\r\n"
>
> -> "HTTP/1.1 403 Forbidden\r\n"
>
looks like this ^^ is your problem, did you setup the certificates
correctly (or disabled certificate checking?) -->
Foreman :: Manual see
section about Authentication for puppetmasters

Ohad

··· On Thu, Mar 14, 2013 at 1:36 AM, Larry Fast wrote:

-> “Date: Wed, 13 Mar 2013 23:21:55 GMT\r\n”
-> “Server: Apache/2.2.15 (CentOS)\r\n”
-> “X-Powered-By: Phusion Passenger (mod_rails/mod_rack) 3.0.17\r\n”
-> “Cache-Control: no-cache\r\n”
-> “X-Runtime: 0.199479\r\n”
-> “X-UA-Compatible: IE=Edge,chrome=1\r\n”
-> “Set-Cookie: _session_id=6a1f5ecc8db4f45894fca16175c1adca; path=/;
HttpOnly\r\n”
-> “Location: https://10.21.12.112/users/login\r\n
-> “Status: 403\r\n”
-> “Content-Length: 1\r\n”
-> “Connection: close\r\n”
-> “Content-Type: text/plain; charset=utf-8\r\n”


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks. Import is now working.