PXE-less discovery host reboots when provisioning

Problem: I use the Foreman discovery iso for pxe-less provisioning of CentOS7 on bare metal hosts with static IP addresses. These are Dell Precision 3430 and do not have legacy BIOS only UEFI. The discovey iso works and creates the host within Foreman. Once provisioning is selected , rather than kexec reloading the kernel, the host reboots and installation does not proceed. I am using the Discovery Kexec template for Red Hat.

**Expected outcome:**kexec loads the kernal and provisioning begins.

**Foreman and Proxy versions:**Foreman 1.20.2

**Foreman and Proxy plugin versions:**Discovery plugin 14


two causes:

  1. Check that Red Hat KExec is associated with your host, if it’s not associated then Foreman falls back to reboot instead kexec.

  2. Your hardware is not kexec friendly, this happens quite a lot unfortunately. We found that kexec workflow is very buggy. Make sure you have the latest FDI image which blacklists some problematic kernel drivers. Also recent findings are that adding “nokaslr” kernel command line option to Red Hat KExec template (when booting discovery) helps.


Try both and report back.

Hi Lukáš

Adding the “nokaslr” kernel command line option resolved this issue.

Red Hat kexec was associated with the host and I was using the latest FDI image, 3.5.1.

Many Thanks

Thanks for getting back to us, looks like this option improves kexec stability a lot.