PXELinux BIOS not loading pxelinux.0 onto tftp server

Problem: I followed all the docs and tutorials as best I understand things but still after creating a new host it’s not loading the full set of files, primarily not seeing a pxelinux.0 file, onto the tftp server so that I can provision a new host.

This is all I get:
[root@foreman tftpboot]# ll *
boot:
total 92992
-rw-r–r–. 1 foreman-proxy foreman-proxy 84752384 Jun 10 11:55 oracle-8-9vxMcO5haIJO-initrd.img
-rw-r–r–. 1 foreman-proxy foreman-proxy 10467936 Jun 10 11:55 oracle-8-9vxMcO5haIJO-vmlinuz

pxelinux.cfg:
total 4
-rw-r–r–. 1 foreman-proxy foreman-proxy 602 Jun 21 09:49 01-52-54-00-b6-25-2c

Expected outcome:
A fully populated tftp directory based on the PXELinux BIOS template

Foreman and Proxy versions:
foreman and proxy v3.2.1

Foreman and Proxy plugin versions:
N/A

Distribution and version:

Other relevant data:

No one has any ideas, eh?

The file pxelinux.0 is deployed by foreman-installer. Investigate that.

The tutorial I watched said that TFTP was enabled by default when running foreman-installer with no options. Afterwards when I figured out that wasn’t the case I simply manually enabled TFTP with foreman-proxy by editing /etc/foreman-proxy/settings.d/tftp.yml. It showed as enabled when I clicked on Infrastructure → Smart Proxies and so I thought I was good. Now I see better.

I ran foreman-installer again with “–foreman-proxy-tftp=true” and voila, /var/lib/tftpboot has all the requisite files now in place. Thank you for pointing me in the right direction.