Python/Gofer dependency errors when installing katello-agent


#1

Problem:
Resolving Dependencies
–> Running transaction check
—> Package katello-agent.noarch 0:3.3.5-4.el6 will be installed
–> Processing Dependency: katello-host-tools = 3.3.5-4.el6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: gofer < 2.12 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: python-pulp-agent-lib >= 2.6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: python-gofer-proton >= 2.5 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: pulp-rpm-handlers >= 2.6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: gofer >= 2.11.5 for package: katello-agent-3.3.5-4.el6.noarch
–> Running transaction check
—> Package katello-agent.noarch 0:3.3.5-4.el6 will be installed
–> Processing Dependency: gofer < 2.12 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: python-pulp-agent-lib >= 2.6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: python-gofer-proton >= 2.5 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: pulp-rpm-handlers >= 2.6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: gofer >= 2.11.5 for package: katello-agent-3.3.5-4.el6.noarch
—> Package katello-host-tools.noarch 0:3.3.5-4.el6 will be installed
–> Processing Dependency: katello-host-tools-fact-plugin for package: katello-host-tools-3.3.5-4.el6.noarch
–> Running transaction check
—> Package katello-agent.noarch 0:3.3.5-4.el6 will be installed
–> Processing Dependency: gofer < 2.12 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: python-pulp-agent-lib >= 2.6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: python-gofer-proton >= 2.5 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: pulp-rpm-handlers >= 2.6 for package: katello-agent-3.3.5-4.el6.noarch
–> Processing Dependency: gofer >= 2.11.5 for package: katello-agent-3.3.5-4.el6.noarch
—> Package katello-host-tools-fact-plugin.noarch 0:3.3.5-4.el6 will be installed
–> Finished Dependency Resolution
Error: Package: katello-agent-3.3.5-4.el6.noarch (SoundHound_soundhound_repos_katello_centos6)
Requires: gofer < 2.12
Error: Package: katello-agent-3.3.5-4.el6.noarch (SoundHound_soundhound_repos_katello_centos6)
Requires: gofer >= 2.11.5
Error: Package: katello-agent-3.3.5-4.el6.noarch (SoundHound_soundhound_repos_katello_centos6)
Requires: python-gofer-proton >= 2.5
Error: Package: katello-agent-3.3.5-4.el6.noarch (SoundHound_soundhound_repos_katello_centos6)
Requires: python-pulp-agent-lib >= 2.6
Error: Package: katello-agent-3.3.5-4.el6.noarch (SoundHound_soundhound_repos_katello_centos6)
Requires: pulp-rpm-handlers >= 2.6
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set ‘notify_only=0’ in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

I do have epel6 repo enabled on the machine through this link: https://dl.fedoraproject.org/pub/epel/6/x86_64/

So I’m not sure why I’m getting dependency errors? Any help would be greatly appreciated!


#2

Do you have the pulp repo

If you install foreman-client-release-1.20.2-1.el6.noarch.rpm on a test system, you’ll see it setup these 4 repositories

[group_qpid-qpid]
https://copr-be.cloud.fedoraproject.org/results/@qpid/qpid/epel-6-$basearch/

[pulp]
https://repos.fedorapeople.org/repos/pulp/pulp/stable/latest/$releasever/$basearch

[subscription-manager]
https://copr-be.cloud.fedoraproject.org/results/dgoodwin/subscription-manager/epel-6-x86_64/

[foreman-client]
https://yum.theforeman.org/client/1.20/el6/$basearch

The missing packages are in that pulp repo.