Restrict gzip while sending report via Email while generating report from job invocation

Currently i am facing issue to get report via Email. All reports sending via email as zipped with gzip. I have selected the output format as CSV but foreman used to send it as zip file while sending it over Email. But if you generate report in console, its coming as expected. I need raw csv in email as well

Expected outcome:
I need raw csv in email as well

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:

Look at the code it seems we look at the gzip parameter. While UI does not expose it in the UI, it may be that we just add a checkbox. I guess you can today trigger the report through API/hammer and you’d get the email with zip.

this has worked for me

hammer report-template schedule --mail-to --id 341 --gzip true

Thanks… But i am getting below error even i have valid report template

[root@xxxxxxuser1]# hammer report-template list

157 Job - Invocation Report

[root@xxxxx]# hammer report-template schedule --id 157 --gzip true
Input job_id: Value can’t be blank

I am getting error “Value cant’t be blank”. But i have valid report template in place with ID 157

Weird, what Foreman version is this? @ofedoren any thoughts? It works for me on nightly setup.