RH content

I’m tying Katello in w/ RedHat Content Delivery to support RHEL clients. I have the Red Hat Enterprise Linux Server 6 RPMs repository selected, sync’ed, a content view created and published, and a composite content view created with the RHEL6 CV contained along with a few other CVs. This has been promoted into a lifecycle environment, and an activation key created with the appropriate repositories enabled.

I have a small RHEL6 client system that’s been provisioned out of the legacy environment here. I can remove the old connection stuff, install the new subscription-manager RPMs along with the CA rpm, and register it successfully. subscription-manager shows the right repos as being available. ‘yum repolist’ or any yum install fails with:

https://[katellohost]/pulp/repos/[orglabel]/[lfe]/[contentview]/content/dist/rhel/server/6/6Server/x86_64/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”
Trying other mirror.
To address this issue please refer to the below knowledge base article

If above article doesn’t help to resolve this issue please open a ticket with Red Hat Support.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-6-server-rpms. Please verify its path and try again

Expected outcome:
The repository should be available

Foreman and Proxy versions:
Fully patched this morning.

Foreman and Proxy plugin versions:

Distribution and version:
Katello is running on CentOS7, client is RHEL6.10

Other relevant data:
I don’t see anything suspicious in production.log. I’m not even sure where else to look.

I’m under the gun on this, I only have a couple of days to get this proven. I have to be doing something simple wrong.

I should also remark that I have CentOS 6 and 7, and Oracle Linux 6 and 7 working just fine.


Hmm have you tried steps listed in https://access.redhat.com/solutions/1256473 . As in

rm -fr /var/cache/yum/*
yum clean all 
yum repolist

Yup. Every time I make a change that may make a change in repository contents or visibility, the client caches get fully cleaned and removed.

This strikes me as an issue on my Katello server, as the repomd.xml files are not downloadable to the client hosts. It’s also apparently RH product specific as I’ve been doing this for some time with CentOS and OracleLinux content.

Something else just crossed my tiny little brain this morning. Am I possibly missing an SSL key? I am downloading and installing katello-ca-consumer-latest.noarch.rpm during my migration script (works pretty well for CentOS and OL,) is there another key that I need to be importing or installing?

Hmm couple of things. I am assuming the you have already tried commenting out or removing the distroverpkg=redhat-release line from /etc/yum.conf before yum repolist (as the access solutions link points out.)
If so can you provide me the name of the Repo you synced ?
Can you also do a ls -l /var/lib/pulp/published/yum/repos/[orglabel]/[lfe]/[contentview]/content/dist/rhel/server/6/6Server/x86_64

I’m not finding that attribute in clienthost:/etc/yum.conf, so commenting or removing shouldn’t have any effect.

Now this is getting more interesting… On the katello server:

$ find /var/lib/pulp/published/yum -type d -name 6Server -print

I do see:

$ ll
total 8
-rw-r--r-- 1 apache apache   2 Aug  6 06:49 listing
lrwxrwxrwx 1 apache apache 101 Aug  6 06:49 os -> /var/lib/pulp/published/yum/master/yum_distributor/78a1c805-cd3a-456d-a5f9-3b2cde6b1cde/1596714351.73

6Server is apparently replaced by 6.10, and the subordinate os directory/symlink does have appear to have valid repodata.

Looks like you might have synced the wrong redhat repository? Can you enable ‘Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server’ or rhel-6-server-rpms and sync that. Looks like your host client wants that.

1 Like