RH kickstart repo question


For a special usecase, I need to have a RH8.3 install that will not be updated.
I mirrored the RH8.3 kickstart repos, and use them for the install, but I can’t see them in the redhat.repo file after installation. Even if they are in my CV and activated.

Did I missed something ?

Try setting your host’s Release version to 8.3. In the web UI: Hosts > All Hosts > your host, then look for the “System Purpose” card on the Overview tab.

If you don’t see 8.3 as an option, you may need to enable and sync the RHEL 8.3 (non-kickstart, AppStream and BaseOS) repos.

My host is seen from foreman as a RH8.3 host. Installation worked, except after it is done I don’t have access to redhat 8.3 repo.
I think this is schizophrenic… I need the kickstart repos to be able to kickstart (even if without foreman it works fine to kickstart from os repo), but after installation these repo are not available. But I can have access to the RH8 RPMs repo (and I don’t want them to keep 8.3 version).

Please whose repo do I need in my Content View and Activation Key to be able to install RH8.3 today ?
I want to install RH8.3, and be able to add/remove rpms if needed, but not any updates.

To do kickstart provisioning for 8.3, you need the 8.3 Kickstart repo.
To get OS updates within 8.3 but not after, you need BaseOS 8.3 and AppStream 8.3 (not 8).

Ok, but there is my situation :

  • Extract from dnf repolist :
    rhel-8-for-x86_64-appstream-rpms Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)
    rhel-8-for-x86_64-baseos-rpms Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)
subscription-manager list
    Statut des produits installés
Nom du produit :    Red Hat Enterprise Linux for x86_64
ID du produit :     479
Version :           8.3
Arch :              x86_64
Statut :            Non abonné
Détails du statut : 
Démarre :           
Termine :           
subscription-manager repos
    Référentiels disponibles dans /etc/yum.repos.d/redhat.repo
ID du référentiel :  rhel-8-for-x86_64-appstream-rpms
Nom du référentiel : Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)
URL du référentiel : https://XXXXXX/pulp/content/XXXXXX/Prod_Emulateur/CV-RH8_3/content/dist/rhel8/$releasever/x86_64/appstream/os
Activé :             1

ID du référentiel :  XXXXXX_epel_8
Nom du référentiel : epel 8
URL du référentiel : https://XXXXXX/pulp/content/XXXXXX/Prod_Emulateur/CV-RH8_3/custom/EPEL/epel_8
Activé :             1

ID du référentiel :  XXXXXX_addons_XXXXXX-el8-addons
Nom du référentiel : XXXXXX-el8-addons
URL du référentiel : https://XXXXXXr/pulp/content/XXXXXX/Prod_Emulateur/CV-RH8_3/custom/XXXXXX_addons/XXXXXX-el8-addons
Activé :             1

ID du référentiel :  codeready-builder-for-rhel-8-x86_64-rpms
Nom du référentiel : Red Hat CodeReady Linux Builder for RHEL 8 x86_64 (RPMs)
URL du référentiel : https://XXXXXX/pulp/content/XXXXXX/Prod_Emulateur/CV-RH8_3/content/dist/rhel8/$releasever/x86_64/codeready-builder/os
Activé :             0

ID du référentiel :  rhel-8-for-x86_64-baseos-rpms
Nom du référentiel : Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)
URL du référentiel : https://XXXXXX/pulp/content/XXXXXX/Prod_Emulateur/CV-RH8_3/content/dist/rhel8/$releasever/x86_64/baseos/os
Activé :             1

But :

dnf update
Updating Subscription Management repositories.
XXXXXX-el8-addons                                                                                                                                                                      42 kB/s | 1.5 kB     00:00    
epel 8                                                                                                                                                                              94 kB/s | 2.3 kB     00:00    
Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)                                                                                                                              187  B/s |  14  B     00:00    
Errors during downloading metadata for repository 'rhel-8-for-x86_64-baseos-rpms':
  - Status code: 404 for https://XXXXXX/pulp/content/XXXXXX/Prod_Emulateur/CV-RH8_3/content/dist/rhel8/8/x86_64/baseos/os/repodata/repomd.xml (IP:
Erreur : Échec du téléchargement des métadonnées pour le dépôt « rhel-8-for-x86_64-baseos-rpms » : Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Why does it try CV-RH8_3/content/dist/rhel8/8/ and not CV-RH8_3/content/dist/rhel8/8.3/ ?

I think it is far too complicated to manage RH repos in foreman.

I missed something somewhere…

# subscription-manager release
Version non définie
# subscription-manager release --set=8.3
Version définie sur : 8.3

and then all repos seems ok.

1 Like

The problem came from my activation key, where the OS version was not specified. Now it works fine.
I’m not very confident with CV, AK and LF mecanisms. Sorry.

1 Like

Glad you got it working :slight_smile: Yeah, release version of the host plays a big part if you’re using the dot repos, as you’ve discovered. The host will not have access unless the release version matches the repo.