RHEL 7.9 foreman-installer failed due to missing "libev.so.4()(64bit)"

Foreman-installer failed on RHEL 7.9 Requires: “libev.so.4()(64bit)”

Expected outcome:
installation completes and outputs proxy urls

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Distribution and version:
RHEL 7.9

Other relevant data:
foreman.log shows
[DEBUG 2023-09-15T18:47:27 main] Provider KafoParsers::PuppetStringsModuleParser not available: /opt/pu$
[DEBUG 2023-09-15T18:47:27 main] No available Puppet module parser found
[DEBUG 2023-09-15T18:47:27 main] Creating execution environment in /tmp/kafo_installation20230915-4448-$
[DEBUG 2023-09-15T18:47:27 main] Configuring Puppet in /tmp/kafo_installation20230915-4448-73uepz
[DEBUG 2023-09-15T18:47:27 main] Writing facts to /tmp/kafo_installation20230915-4448-73uepz/facts

Hey there!

Support for EL 7 was removed with Foreman 3.4. (one of the refs or another here)

So, as you can see here currently only EL 8 distros are supported/it’s only possible to install Foreman + Katello on. (For a Foreman only installation it’s also possible to install on Debian 11 and Ubuntu 20.04)

Making it work on EL 9 is under work right now and can be tracked here.

Thank you, tried install on EL 8 and worked smoothly. was lead off by EL 7 option on Foreman :: Quickstart

1 Like

Okay great if that worked!
Make sure you are looking at the docs for the correct version:

And soon these new docs will fully replace the old page:
(There will also be one for Foreman only)