RHEL 9 install using http-proxy does not work anymore (worked for RHEL 8)

I use a proxy to use RHEL 9 https server for installation media (extract of the RHEL 9.1 iso).
I worked perfectly using http-proxy and http-proxy-port parameters with RHEL 8.

The server correctly got the ks file but then after the PXE boot to the RHEL 9 kernel and initrd but then tell :
dracut-initqueue : warning : can’t find installer main image path in .treeinfo
…(time time time…)
dracut-initqueue : curl : (28) Failed to connect to my-http-server port 443 : connection timed out

When finally the install procedure give me the dracut shell, I can correctly download the .treeinfo using the proxied curl to the server etc.

Any idea please ?

Console tells

Foreman and Proxy versions:

Distribution and version:
RHEL 9.1

Here is the head of the kickstart file :

Location: Default Location

url --url https://my_http_server/external/redhat/9.1 --proxy=http://my_http_proxy_server:3128

lang en_US.UTF-8
selinux --permissive
keyboard fr

network --device=00:50:56:ac:99:16 --hostname my_fqdn_server_to_install --noipv6 --bootproto static --ip=my_private_ip --netmask= --gateway=my_private_fateway --mtu=1500 --nameserver=my_dns_server

rootpw --iscrypted $5$IdR7FZx7Epfl2q7t$6qYH7fgw9rpvSOEZZMXI395Bk4fXrUX4Jb9C2/8VYP5
firewall --service=ssh
authselect --useshadow --passalgo=sha256 --kickstart
timezone --utc UTC

services --disabled gpm,sendmail,cups,pcmcia,isdn,rawdevices,hpoj,bluetooth,openibd,avahi-daemon,avahi-dnsconfd,hidd,hplip,pcscd

bootloader --location=mbr --append=“nofb quiet splash=quiet”

One more precision today. It seems more related a RHEL 9 kictstart issue.

When I use the kickstart converter from 8 to 9 : Login - Red Hat Customer Portal to check the kickstart file with the proxy option assigned to the url keyword,
It crosses out the proxy and noverysslssl options as they would not be available anymore.

Whereas these options are still available in the reference guide of the RHEL 9:

Any ideas ?

For RHEL 9 we use kickstart_rhsm snippet, where I don’t see anything with http proxy in the rhsm command.

There is right now open PR waiting for author’s response that should fix your issue.

Thank you.
For information RHEL 9 is bugged : 2177219 – [Regression] Proxy specified in kickstart through "url" stanza is not taken into account
Just admitted today by RH.