Ruby dependency could not be installed

Using the offical quick start guide, the command
sudo apt-get update && sudo apt-get -y install foreman-installer
aborts with an error stating that foreman-installer hat unmet dependencies (ruby).

Expected outcome:
Command should work without error.

Foreman and Proxy versions:
Foreman Version 3.9

Foreman and Proxy plugin versions:
Foreman Plugins Version 3.9

Distribution and version:
Debian 11.8

Other relevant data:

Error Code

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
foreman-installer: Depends: ruby but it is not installable or ruby-interpreter but it is not installable
Depends: ruby-kafo (>= 7.3.0) but it is not going to be installed
Depends: ruby-kafo (< 8.0.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

my sources.list file includes two entries:

deb Index of /debian-security bullseye-security main contrib

deb-src Index of /debian-security bullseye-security main contrib

Is there any other source that has to be added to the sources.list file?

Thanks in advance!

Not a Debian person, but I think you are missing some of the default repos.
I would expect your sources.list to look something like this:

deb bullseye main contrib
deb-src bullseye main contrib

deb bullseye-security main contrib
deb-src bullseye-security main contrib

deb bullseye-updates main contrib
deb-src bullseye-updates main contrib

If the bullseye-security repos are the only ones enabled, I assume you won’t find a lot of packages that are expected to be available in Debian by default.

1 Like