Rubygem-foreman_monitoring-3.0.0-1.fm3_10.el9.noarch fails to install

Problem:
rubygem-foreman_monitoring-3.0.0-1.fm3_10.el9.noarch does not install due to rake error created by db/migrate/20221026065954_fix_monitoring_settings_category_to_dsl.rb

Expected outcome:
foreman_monitoring plugin gets installed

Foreman and Proxy versions:
3.10

Distribution and version:
CentOS Stream release 9
Linux 5.14.0-447.el9.x86_64 #1 SMP PREEMPT_DYNAMIC Tue May 7 10:46:15 UTC 2024 x86_64 x86_64 x86_64

Other relevant data:
The fix has been committed to github by ekohl and authored by stejskalleos already over a year ago in commit Migration error 'column settings.category does not exist' · theforeman/foreman_monitoring@f7aca84 · GitHub but it has not released.

I’ve started the release process here:

Updates for 3.9 and 3.10 are out, enjoy!

1 Like

Note there’s still Fix Foreman legacy UI erroring out by ananace · Pull Request #92 · theforeman/foreman_monitoring · GitHub which is still breaking the UI. Luckily it’s only the legacy host detail page. Add a monitoring tab on the modern host details page by ekohl · Pull Request #94 · theforeman/foreman_monitoring · GitHub was my attempt to convert it to the modern host detail page.

If someone wants to step up in helping to maintain foreman_monitoring, they’d be more than welcome.