Run jobs only uses first 20 hosts

When I select more than 20 hosts on the All Hosts page and choose action “Schedule Remote Job”, the job will only run on the first 20 hosts selected. On the “Target hosts and inputs” page it lists 20 hosts and shows “Apply to 20 hosts”.

If I switch to the legacy form I see the correct count and correct list of hosts. It will run on any number of hosts selected

Expected outcome:
Run a job on more than 20 hosts using the new form.

Foreman and Proxy versions:

Distribution and version:
AlmaLinux 8.9

If you turn on the experimental All Hosts page, the select all functionality should work better there. I think this bug has been around quite some time.