Safemode doesn't allow to access

When building a server i get the error in the image attached.

This is a fresh Foreman 3.7 build with all the default templates. Is this a bug? Any pointers on how I can fix this outside of removing the snippet from all the said templates?

Screenshot 2023-09-24 at 17.26.28

What plugins do you have enabled? Do you have katello?

in this depoloyment it is just foreman 3.7. no Katello.

see attachments
Screenshot 2023-09-25 at 11.28.43

Screenshot 2023-09-25 at 11.28.19

That’s odd. The codepath with subscription_manager_configuration_url shouldn’t be called at all, unless the host has kt_activation_keys parameter set, which should be unset if you don’t have katello. Does the host (or its hostgroup) have this parameter set?

Thanks @aruzicka. That was the problem. I have an old script that I used when setting up Katello that I used when setting up this foreman instance. The script would create some global parameters and kt_activation_keys was one of them. kt_activation_keys was defined via this script but had no value. Deleting this global parameter fixed the safemode issue.