Setting oVirt hardware profile - Spice, Thin Provisioning of disks, and VM name in the console

Hello Eric,

I'd like to know about these things as well and also it would be nice to know if it possible to enable high availability via Foreman?

#3, what version you are using? I saw same behavior on 1.1 but I think it has been fixed already (although I'm not sure and I'm not able to test this right away)

-samuli

Eric du Toit <eric.dutoit@gmail.com> kirjoitti 5.3.2013 kello 1.40:

··· > I think I've checked everywhere I know to check to find this information. If I missed something, my apologize in advance. > > There are three things I'm trying to accomplish when I provision a new Virtual Machine in Foreman using oVirt as a compute resource: > > #1) I'd like the default Console client to be setup as Spice instead of VNC. > #2) I'd like the disks to be provisioned as a raw storage instead of thin provisioned / sparse > #3) I'd like to name of the VM found in the oVirt console to reflect the actual hostname I gave instead of foreman_1362xxxxxx > > Can you give me a hint on where I can find any or all of these switches to flip? > > -- > Eric > > -- > You received this message because you are subscribed to the Google Groups "Foreman users" group. > To unsubscribe from this group and stop receiving emails from it, send an email to foreman-users+unsubscribe@googlegroups.com. > To post to this group, send email to foreman-users@googlegroups.com. > Visit this group at http://groups.google.com/group/foreman-users?hl=en. > For more options, visit https://groups.google.com/groups/opt_out. > >

Eric du Toit <eric.dutoit@gmail.com> kirjoitti 5.3.2013 kello 18.42:

>
>
> I'd like to know about these things as well and also it would be nice to know if it possible to enable high availability via Foreman?
>
> #3, what version you are using? I saw same behavior on 1.1 but I think it has been fixed already (although I'm not sure and I'm not able to test this right away)
>
>
>
> Hi Samuli,
>
> I'm running Foreman 1.1stable. I setup the Foreman yum repository and here are the packages I have installed:
> # rpm -qa | grep ^foreman

Sorry for the delay with my answer. I just checked and I'm currently running following packages:
foreman-1.1stable-2.el6.noarch
foreman-sqlite-1.1stable-2.el6.noarch
foreman-ec2-1.1stable-2.el6.noarch
foreman-ovirt-1.1stable-2.el6.noarch
foreman-mysql-1.1stable-2.el6.noarch
foreman-proxy-1.1stable-1.el6.noarch
foreman-libvirt-1.1stable-2.el6.noarch

I created new VM with Foreman using RHEV 3.1 and hostname matches in RHEV Manager and Foreman (host-domain-tld shown in both). I think I can test this also with oVirt 3.2 if needed.

-samuli

··· > On Tuesday, March 5, 2013 7:27:38 AM UTC-6, Samuli Heinonen wrote:

I'm also running RHEV3.1, but my VMs receive a name of foreman-xxxxxxx
instead of hostname. I'll dig through the configs and yaml files to see if
I can find where that is set, but if anyone knows why this might be
happening, I'd love to avoid a dig.

··· On Thursday, March 7, 2013 6:01:36 AM UTC-6, Samuli Heinonen wrote: > > > Sorry for the delay with my answer. I just checked and I'm currently > running following packages: > foreman-1.1stable-2.el6.noarch > > I created new VM with Foreman using RHEV 3.1 and hostname matches in RHEV > Manager and Foreman (host-domain-tld shown in both). I think I can test > this also with oVirt 3.2 if needed. > >

>
>
>>
>> Sorry for the delay with my answer. I just checked and I'm currently
>> running following packages:
>> foreman-1.1stable-2.el6.noarch
>>
>> I created new VM with Foreman using RHEV 3.1 and hostname matches in RHEV
>> Manager and Foreman (host-domain-tld shown in both). I think I can test
>> this also with oVirt 3.2 if needed.
>>
>>
>
> I'm also running RHEV3.1, but my VMs receive a name of foreman-xxxxxxx
> instead of hostname. I'll dig through the configs and yaml files to see if
> I can find where that is set, but if anyone knows why this might be
> happening, I'd love to avoid a dig.
>

I cant reproduce this either… if you are creating vms via foreman hidden
url (/compute_resources/id/vms/new) then it would default to such a name,
however, if you create the vm via the host tab (new host) then I'm not sure
how this happens (as the current hostname should always override the
foreman randomly generated hostname )

foreman latest develop branch did get a few more ovirt releated updates
(like the disk lock issues, and spice over html5 etc), might worth trying
to use that and see if the problem still occurs?

the relevant place in the code that generates the foreman-xxx names is at:


but this should be overwritten every time using the new hosts form.

Ohad

··· On Mon, Mar 11, 2013 at 8:50 PM, Eric du Toit wrote: > On Thursday, March 7, 2013 6:01:36 AM UTC-6, Samuli Heinonen wrote:


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.