Setting up katello bastion

I am trying to set up katello for string extaction (bastion actually). I am having issues with phantomjs

Is there a specific version of npm I should be using? I am on Fedora 28, ruby 2.3.4,

@Bryan_Kearney Which command are you running? I can try the same locally and see if I hit the same.

At first glance, it looks like you have phantomjs installed globally and its causing some permission errors. You can try npm ls -g | grep phantomjs to check if its installed globally. If that returns something, run npm uninstall -g phantomjs to uninstall it globally, then try again.

I also found this github issue, which seems to be a similar error and it looks like this comment is the solution.

@John_Mitsch that command

did work, but I am still getting issues when I run the bastion:setup command from katello/engines/bastion_katello

@Bryan_Kearney I do get
Error checking path, continuing { Error: Cannot find module '/usr/lib/node_modules/phantomjs/lib/location'
but everything completes successfully after that, so it doesn’t seem to be affecting anything.

I don’t see
Error: EACCES: permission denied, mkdir '/usr/lib/node_modules/phantomjs/lib/phantom'
so I’m guessing that is your blocking error.

I think the setup script reinstalls phantomjs globally, so you could try uninstalling it and then physically removing it from the filesystem, since the path seems to be where the issue is:

sudo npm uninstall -g phantomjs phantomjs-prebuilt
sudo rm -rf /usr/lib/node_modules/phantomjs

then you can try the setup command again.

reposting with a public pastebin wince I am an idiot

Have you tried running an npm i instead of using the rake command? I personally have never used the rake command.

I tried both and alot. IMHO tihs part of the docs could be improved a bunch. @John_Mitsch had me set up a dev box via forklift. This got me running and leads me to believe that I can not do dev on F28.