SLES15SP4 - registration worked, but no subs, no repos

First off, I am running an eval of ATIX’ Orcharhino 6.4, which amounts to according to the “About” dialogue, foreman 3.3.1 and katello 4.5.1 (on the same host).

I’m only posting here because the thing is close enough to a plain-vanilla foreman and I believe it’s a user-error anyway, which I hope someone can point me to…

I didn’t do any provisioning, so the SLES is manually installed and then registered (which worked, after figuring out the command-line and all the additional repos that had to be given to it).

So, the host is “orange” in the GUI and it says “No installed packages and/or enabled repositories have been reported by katello-host-tools.”

On the host itself:

host2:~ # subscription-manager list
No installed products to list
host2:~ # subscription-manager list --consumed
No consumed subscription pools were found.
host2:~ # subscription-manager repos
This system has no repositories available through subscriptions.

Clearly, something is missing.

The activation key has the various repos and subscriptions added.
The host group has the relevant lifecycle environment, content view and the activation key added.

The subscriptions are “available” (subscription-manager list --available), but I can’t seem to get the system to “consume” them.

Is there a way to gather just about what it is missing?

Subscriptions must be attached to hosts, if you’re not using Simple Content Access.

I’m guessing you just need to run subscription-manager auto-attach?

I already ran that.

I says “Auto-attach preference: enabled”.

But I still see no subscriptions attached.

Hi Rainer,
I’d recommend to open an issue in the ATIX support portal.
I’m pretty sure you’ll get the help you need there :wink:

Best regards,

Yeah, I know.

Just I don’t have the details and my co-worker is on vacation.

I noticed this already when I was testing with Foreman and CentOS back then that when the “subscriptions” don’t “work” it’s almost impossible to track down why.

I was really looking for a (programatic) way to verify the settings.


The procedure for registering SLES hosts is described here: Registering Hosts - orcharhino documentation

and here for the manual steps using subscription manager: Registering Hosts - orcharhino documentation

I just verified in our system that you should have received an invitation for the ATIX service portal. Can you please check your emails for this?

Best regards,

Yes, writing a ticket.

Anyway, the registration itself worked.

It’s just that it seems it doesn’t see any updates I publish and promote (because, I assume, it doesn’t have subscriptions).

Thanks a lot!

For the curious,

so it seems that the activation key did not have the necessary subscriptions added when the system was initially registered.

After re-registering the system again and forcing the activation-key, things started to work.