Smart-Proxies on Windows 2012 no A record

proxy

#1

Problem:
No DNS A record.
Expected outcome:

Foreman and Proxy versions:
1.21.3
Foreman and Proxy plugin versions:
windows smart-proxies 1.22.0-RC2
Other relevant data:
In my infrastructure I have configured the smart-proxies on dc windos 2012.
In smart-proxies I have dhcp (: use_provider: dhcp_native_ms) and dns (: use_provider: dns_dnscmd).
When I create a new machine, if it makes the reservation ip and creates the reverse record in the dns.


#2

Do you have the Foreman DNS proxy associated in the Foreman Domain?


#3

I am running into the same problem since I updated to 1.21.3.
I was getting errors when deploying a VM that “dns record cannot be set”.
First of all, my dns-provider settings under /etc/foreman-proxy/settings.d/dns_nsupdate.yml were wiped so I had to reconfigure it. Then I restarted services and I did not get the error messages when deploying a VM so it seemed fixed at first. But then I checked my DNS and the records don’t appear. I set the DNS-proxy correctly for the domain and the reverse-proxy correctly for the subnet, yet both do not work.


#4

What wiped the settings and how did you set those options? Manually or via the installer? Which OS and version?

Is there a mismatch between taxonomies (organizations or locations that don’t match)?


#5

I can’t really tell what wiped the settings but it seems to be coming from the update routine.
I set these options manually after installation. My smart proxy is running on CentOS 7.6
No mismatches in locations and organizations.
When I use the nsupdate utility manually it correctly makes a new A record in my dns.


#6

Hi!
Yes I have the smart-proxy associated.
My smart-proxy is a windows 2012 dc.
Any idea?. How can i debug?