Smart proxy content synchronize is stuck

katello
proxy

#1

Hello,
Version: Katello 3.5 / Foreman 1.16 (Installed via Katello) + smart proxy in different network.
From katello server, running:
hammer proxy content synchronize --organization-id 3 --id 3
but it’s stuck forever on 9%
On smart proxy all tasks like this one:
pulp-admin tasks list
±---------------------------------------------------------------------+
Tasks
±---------------------------------------------------------------------+
Operations: sync
Resources: 3-ol7_content-ol7_env-b502f745-6979-493a-990b-2e0ec2fd7609
(repository)
State: Waiting
Start Time: Unstarted
Finish Time: Incomplete
Task Id: d5653f61-9663-4ebf-8a6c-b2beb91fea16
Worker Name: None

From Monitor: “Waiting for Pulp to start the task”

Any help will be appreciated


#2

What is the status of your pulp services?

katello-service status

# and this also

hammer ping

If there’s something amiss, try restarting:

katello-service restart

#3

Hi ludaca,

Make sure that /var/lib/pulp and /var/lib/mongodb has plenty of free space. Also, is there a firewall between the master and the proxy? Is iptables or firewalld running on either foreman/katello host? If so, have the necessary ports been opened? TCP/9090, TCP/443 and TCP/80 from memory…

How about selinux (execute “getenforce”)? Is it enabled? Do you see any denies? Try turning it off temporarily (on both hosts) with “setenforce 0” and try a sync again…

Hope this helps…

Les


#4

Hi,
Thank you all for your replays!

katello-service status

The last line is:

  • All services are running [OK]
    But a message that could worry me:
    pulp[29589]: celery.beat:INFO: Scheduler: Sending due task download_deferred_content (pulp.server.controllers.repository.queue_download_deferred)

#hammer ping
candlepin:
Status: ok
Server Response: Duration: 12ms
candlepin_auth:
Status: ok
Server Response: Duration: 11ms
pulp:
Status: ok
Server Response: Duration: 37ms
pulp_auth:
Status: ok
Server Response: Duration: 18ms
foreman_tasks:
Status: ok
Server Response: Duration: 3ms

katello-service restart not helping

No free space problem, firewalld and selinux disabled
Yes, there is firewall between master and proxy, I’ve found only 9090 is not opened from proxy to master
direction ( will take a few days to open it - in enterprise company )
May it’s the problem, because I’ve found on RedHat site this check:
Check/verify ssl connection between Satellite and Capsule servers by:

From proxy server:
 curl --cert /etc/foreman-proxy/foreman_ssl_cert.pem --key /etc/foreman-proxy/foreman_ssl_key.pem --cacert /etc/foreman-proxy/foreman_ssl_ca.pem https://satellite.example.com:9090/features

#5

Hi,
The ports are opened, but proxy content synchronization still stuck.

There are two tasks in this state:
Actions::Pulp::Consumer::SyncCapsule
State: waiting for Pulp to finish the task
All the rest:
Actions::Pulp::Consumer::SyncCapsule
State: waiting for Pulp to start the task

What else can be done?


#6

Hi Ludaca,

How long did you let the sync run for? It may take a bit.


#7

At least 24 h