Smart Proxy not detected?

Ive tried this with Puppet 5 and Puppet 6 (I have done this also previous years without problems since I teach this once per year)

foreman-installer \
 --enable-foreman-proxy \
 --foreman-proxy-tftp=false \
 --foreman-proxy-dhcp=false \
 --foreman-proxy-dns=true \
 --foreman-proxy-dns-managed=true \
 --foreman-proxy-dns-interface=ens3 \
 --foreman-proxy-dns-zone=borg.trek \ \
 --foreman-proxy-dns-forwarders= \
 --foreman-proxy-dns-provider=nsupdate_gss \
 --foreman-proxy-dns-server= \
 --foreman-proxy-dns-tsig-keytab=/etc/foreman-proxy/dns.keytab \
 --foreman-proxy-dns-tsig-principal=foremanproxy@BORG.TREK \

Installing             Done                                               [100%] [....................................................]
  * Foreman is running at https://manager.borg.trek
      Initial credentials are admin / **********
  * Foreman Proxy is running at https://manager.borg.trek:8443
  * Puppetmaster is running at port 8140
  The full log is at /var/log/foreman-installer/foreman.log

The log include the line
[DEBUG 2019-06-26T10:11:22 main] Datacat_collectorforeman_proxy::enabled_features: Collected {“features”
=>[“DNS”, “Puppet”, “Puppet CA”, “Logs”]}
with only http 200/201 following and no errors

**Infrastructure -> Smart Proxies **
only says "Create Proxy"
and if I try to create a proxy with URL
it says “Only one declaration of a proxy is allowed”

Previous years, manager.borg.trek has always showed up as the Smart Proxy with Puppet and DNS, I wonder why it does not do that anymore?

any help greatly appreciated!

I believe this hints towards the proxy already being defined, but in another organization and/or location than you currently are. Could you set those to any/any and check Infrastructure > Smart Proxies again?

1 Like

Thank you so much! Changed organization and location to Any and problem solved :slight_smile: