Smart Variables are not vising from Host group (Foreman 3.5)

Smart Variables are NOT visible from Host Group > parameters tab (However it is visible on individual host > parameters)
Also Smart Variable tab under Configure > Puppet Enc (Older version it is showing)
Expected outcome:
Because of host group > parameter tab we can’t add /change parameters based on group.

Foreman and Proxy versions:
Foreman 3.5.1
proxy: 3.5.1-1.el8

Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:

I don’t understand the problem.

With foreman 3.5 in English there is the menu ‘Configure - Smart Class Parameters’ (in the Puppet ENC section of the Configure menu) where you see all imported puppet class parameters.

“Smart” is the old naming and it’s replaced by “Puppet” as the origin in the course of the move from the core into the puppet plugin.

There are “Puppet Class Parameters” listed on the “Puppet ENC” tab of the edit pages for host groups as well as individual hosts. They are NOT on the “Parameters” tab, but again on both.

Of course, it lists only parameters which are set to override for the puppet classes selected for that host group or host.

If you don’t select any puppet class for a host or host group, it won’t list any puppet class parameters.

If you select only puppet classes which don’t have any parameter set to “override”, it won’t list any puppet class parameters.

Thanks for the reply, let me give little more details.
When I add (import puppet modules, which are on production environments), every modules got imported.
However when I create Hostgroup (Base) add few modules to it showing warning “Some Puppet Classes are unavailable in the selected environment”
Note: I have only one environment (Production)
Though the warning sign showing all models added to the group. Now if i check Hostgroup > Parameters NOT showing any predefined parameter part of the puppet modules that selected to the hostgroup.
Where as if check a server that associated with the base group showing predefined parameters.

Probably we need to fix the issue with “Some Puppet Classes are unavailable in the selected environment”

Any thoughts?

It’s does that for a long time. It’s a bug. Bug #34402: Hostgroup error: Some Puppet Classes are unavailable in the selected environment - Puppet - Foreman Simply ignore the error. There is none.

As I wrote before: Puppet parameters are NOT on the “Parameters” tab. It’s pointless to look for them on the “Parameters” tab. There are no parameters from the puppet plugin on the “Parameters” tab. Really. They are not on the “Parameters” tab but on the “Puppet ENC” tab. You have to look on the “Puppet ENC” tab. It shows included and available classes at the top and the overridden puppet class parameters at the bottom, if the included classes have some parameters set to override.

On the “Puppet ENC” tab.

But as I also mentioned before: it doesn’t show all parameters of all puppet modules, but only those, which you have configured to override.You wrote your imported the modules and then expected puppet parameters to show up. But that’s not how it works. If you don’t set any parameter of any module to override, you’ll never see any puppet parameter listed on the hostgroup or host page.

You import the module, then set some of the smart class parameters to override and then you can see those parameters on the “Puppet ENC” tab on the host or hostgroup page, if you selected the puppet module for those overridden parameters.

So go to Configure - Classes and select a class to override parameter for a class, or go the way of Configure - Smart Class Parameters and select from a list of all parameter names of all imported modules.

See also Configuring Hosts Using Puppet