Subscription Manager for Debian & Ubuntu on

I was able to reproduce the same behaviour and opened an issue: Issue #8828: Synchronizing buster/updates succeeds but does not download any packages - Debian Support - Pulp
Looks like a bug.

1 Like

@techietubby I mate the same problem as you (0 packages) from security repo.

You can try this :
debian security:
Upstream URL: Index of /debian-security
Releases: buster/updates
Architectures: amd64

And sync again.

I’m not at office so I’m not sure if Components OR Architecture should be empty (both works). I try this by reading it : GitHub - ATIX-AG/errata_server: Provides access to Debian/Ubuntu errata generated via the errata_parser companion project via an HTTP interface.

“Note that filtering by “releases” and “components” will generally eliminate entire errata, while filtering by “architectures” will simply result in errata that do not contain the binary packages of the architectures not filtered for.”

It’s not relevant to Katello, but it makes me think that maybe filters on debian security repo are not working with the current version of pulp_deb plugin (python3-pulp-deb-2.9.1-1.el7.noarch.rpm).

I have actually fixed the problem with the 0 packages from debian-security (the fix is available in the pulp_deb 2.13.0 release, but probably won’t be available within Katello for some time). The Problem was 100% the component. For debian-security the components are named updates/main in the Release file, instead of just main. As a result when you set Components: main in Katello (that is in the pulp remote), it does not find any components with that name and therefore does not sync anything but the metadata. You should be able to work around the problem by using Components: updates/main instead. The fixed version of pulp_deb will work with either entry (main as well as updates/main).

Not setting any component also works.

1 Like

Great news ! Thank you @quba42.

It didn’t work for me. I am trying to install subscription-manager on Ubuntu 16.04.7(Xenial). I added Debian 10 repository but apt-get is unable to locate the package:

root@vm253:~# cat /etc/os-release
VERSION="16.04.7 LTS (Xenial Xerus)"
PRETTY_NAME="Ubuntu 16.04.7 LTS"

root@vm253:~# grep -r --include '*.list' '^deb ' /etc/apt/sources.list 
/etc/apt/sources.list.d/ | grep atix
/etc/apt/sources.list:deb stable main
root@vm253:~# apt-get install -y python-subscription-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python-subscription-manager

Any clue?

I strongly discourage using the subscription-manager packaged for Debian 10 on Ubuntu 16.04.

However, I was able to install subscription-manager in a Ubuntu 16.04 container:

apt-get update && \
apt-get install -y wget && \ 
wget -qO - | apt-key add - && \
echo "deb stable main" >> /etc/apt/sources.list && \
apt-get update && \
apt-get install -y subscription-manager && \
subscription-manager version

This results in the following error:

Unable to find Subscription Manager module.
Error: cannot open shared object file: No such file or directory

Note that this does not use https to download the packages.

I am getting the same error my side

Hi everyone,

I am right jumping into this discussion too. We just managed to get a subscription-manager running on a fresh Ubuntu 20.04, thanks to apt.atix :grinning:
Registering the host worked, we do have repos for Ubuntu, they sync every day. When I use subscription-manager repos --list, I get four repos back (three for Ubuntu, one for atix).
When I manually type apt update, apt runs against our foreman server and I get a list of upgradable packages. However, I don’t see theses packages under Hosts → All Hosts or Hosts → Content Hosts.
I do have this error messages:
" No installed packages and/or enabled repositories have been reported by subscription-manager."
and under provisioning details:
“Status: Error
Operating System: Ubuntu 20.04”

I mean, it works somehow, but not completely :frowning: We can update via our foreman server, but it would be nice, to get the info about available updates, too.

What am I missing? Any ideas?

With kind regards,


More info: Under Hosts → content hosts → Details, in the Networking tab I just see as IPv4 address, and not the real address. It looks like as the subscription-manager just reported the loopback device and not the ens162, as it does with our CentOS hosts.

Our architecture is x86_64. The architecture in our product/repo is amd64, though. I’ve read that there’s a bug that you don’t see any repos back if you use amd64. But subscription-manager repos --list does give us our repos…

Can you try installing/removing any package on the host? I think the package-upload only runs when dpkg really (un-)installs a package.

Alternatively, it should be possible to run the package-upload script directly:


Hi, thank you for the reply. We did this, manually installed PHP 7.4. After a while it shows up under Content Hosts → installed packages. But we do have an “Unknown subscription status”. Even after a subscription manager fresh etc.
I wonder what I am missing here…

@Nordishbynature maybe you are looking for Errata? check: Spacewalk User new to Foreman near the end. Errata for Debian-like systems is not supported, yet.


Hi kalessin,

thank you for the answer. I’ve followed the link and therefore also found your answer and this link:

shows, that it’s just not ready yet.


I tried installing subscription-manager on Debian 11 (bullseye), but it fails due to several missing and not installable dependencies. They are only available in their python3 versions.

# dpkg -i python-subscription-manager_1.25.1-4_amd64.deb                                      
(Reading database ... 42624 files and directories currently installed.)
Preparing to unpack python-subscription-manager_1.25.1-4_amd64.deb ...
Unpacking python-subscription-manager (1.25.1-4) over (1.25.1-4) ...
dpkg: dependency problems prevent configuration of python-subscription-manager:
 python-subscription-manager depends on python-dateutil; however:
  Package python-dateutil is not installed.
 python-subscription-manager depends on python-ethtool; however:
  Package python-ethtool is not installed.
 python-subscription-manager depends on python-iniparse; however:
  Package python-iniparse is not installed.
 python-subscription-manager depends on python-six; however:
  Package python-six is not installed.
 python-subscription-manager depends on python-dbus; however:
  Package python-dbus is not installed.
 python-subscription-manager depends on python-rpm; however:
  Package python-rpm is not installed.
 python-subscription-manager depends on virt-what; however:
  Package virt-what is not installed.
 python-subscription-manager depends on python-debian; however:
  Package python-debian is not installed.
 python-subscription-manager depends on python-apt; however:
  Package python-apt is not installed.
 python-subscription-manager depends on python-gobject; however:
  Package python-gobject is not installed.
 python-subscription-manager depends on python-decorator; however:
  Package python-decorator is not installed.
 python-subscription-manager depends on apt-transport-katello; however:
  Package apt-transport-katello is not installed.

dpkg: error processing package python-subscription-manager (--install):
 dependency problems - leaving unconfigured
Processing triggers for dbus (1.12.20-2) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
root@ethel-alcosiba:~# cat /etc/debian_version 

The Ubuntu 20.04 version does not work, either, due to higher Python 3 version on bullsyeye.

# apt-get install -y python3-subscription-manager
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
python3-subscription-manager is already the newest version (1.25.1-4).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 python3-subscription-manager : Depends: python3 (< 3.9) but 3.9.2-3 is to be installed
                                Depends: python3-dateutil but it is not going to be installed
                                Depends: python3-ethtool but it is not going to be installed
                                Depends: python3-iniparse but it is not going to be installed
                                Depends: python3-six but it is not going to be installed
                                Depends: python3-rpm but it is not going to be installed
                                Depends: virt-what but it is not going to be installed
                                Depends: python3-debian but it is not going to be installed
                                Depends: python3-decorator but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

We are working on publishing subscription-manager for Debian 11 on soon! I will keep you posted.


Update: We’ve published subscription-manager and katello-host-tools for Debian 11 ‘Bullseye’ on


You also removed the Debian 10 repo. Any chance of restoring this repo?

Thank you.

Yes, we are hearing the feedback of the community loud and clear.

I will have a look at this on Monday.


You rock! Thanks for bringing that repo back up. :star_struck:


Yes, it’s back: we’re (again) providing subscription-manager and katello-host-tools for Debian 10 on

Thanks for your feedback!