Subscriptions activation keys invalid subscriptions?

I am facing with foreman, The issue is as described below:

I have activation keys that each has a different set of products and subscriptions repository. When I subscribe a system “RedHat 6.9 hosts” to the foreman, after going through the steps of s-m :slight_smile:
1- Curl -o katello-consumer-noarm.rpm
2- rpm -ivh katello-consumer-noarm.rpm
3- s-m register --ORG “” --ACTIVATIONKEY=""
4- install katello-agent

I see few things.
the “subscription-manager status” shows
System Status Details
Overall Status: Invalid

Red Hat Enterprise Linux Server:

Not supported by a valid subscription.
You have mail in /var/mail/root

On foreman-webui I get the red circle and x saying the system is not being managed.

And when I run “subscription-manager list --available” I see pool IDs for different products.

Forman Version 1.15.6

Any ideas why?

No one can solve this mystery?

I guess this one slipped past :slight_smile: - let’s see if @katello can offer any opinions…

Do you have placed your redhat manifest in katello? For running RHEL you need to have the manifest on your foreman / katello so that the RHEL host has a valid subscription. The subscription is part of the manifest which you normally can download from redhat.

Hello Bernhard,

Does each activation key requires a RedHat manifest? Because I do have three manifests imported successfully.

Can I upload multiple manifests to foreman?

You don’t need to have a manifest for each activation key but you need to make sure, that you have selected the RHEL server subscription for your activation key.

It’s possible to upload multiple manifests.

on uploading another manifest I am getting this error : Owner has already imported from another subscription management application.

I read on Red Hat that many people delete the old in order to upload the new manifest. refresh manifest option didn’t help.

OK so the subscription issue I have solved it. The issue was that the manifest was attached to foreman it didn’t have any valid subscription, the admin who created didn’t attach and subscription which caused a failed status of syncing or managing the repos. I have removed that one from foreman, created new one from RedHat and uploaded the new one then synced the repos.

@Bernhard_Suttner thank you for bringing up the manifest subject.

@Gwmngilfen I can’t mark it as solved will you please mark it as solved.

You should have option as you’re the thread owner. It’s in the “…” expandable menu on the post you want to mark - it’s definitely not there?

I don’t see the option where to close the ticket or mark it as solved.

I marked it for you. for future reference - to mark a reply as the solution, you need to click on the three dots icon below it, then select the icon with the check mark.

1 Like

Got it. Thank you very much. I didn’t know that selecting the answer will mark the case as solved.