Suse products are not getting synchronized in the Foreman UI

Problem:
I have installed SCC plugin and I am able to test the connection, but products are not getting synchronized, task is getting completed without any error.
It worked once, but products were showing in Default Org and because of which i have restored the VM snapshot and again installed Suse plugin now task is getting completed but products are not getting synchronized.

Expected outcome:

It should show the available products from the Suse subscriptinos.

Foreman and Proxy versions:
foreman-release-2.0.1-1.el7.noarch
foreman-proxy-2.0.1-1.el7.noarch

Foreman and Proxy plugin versions:

Distribution and version:
katello-3.15.2-1.el7.noarch

Other relevant data:
There are no error logs, tasks is getting completed but products are not syncing in the foreman.

Can someone share any details on this?

Judging from your Katello-version, I assume you use pulpcore (aka. pulp3) already.
The reason for the problem you have is probably this issue, which will be fixed in Katello 4.0 (and also requires a fix in pulpcore’s yum/rpm-plugin): Bug #30752: Set sles_auth_token in yum-repository form for synching SLES-repos from SCC - Katello - Foreman

You might want to switch back to pulp2 from pulpcore, if that is an option for you.

The used pulp-version can be determined by looking at Infrastructure->SmartProxies:

If the content-type yum is shown under pulpcore, you are using pulpcore, which has the mentioned bug as far as SCC-repositories are concerned.

1 Like

Hello, Thanks for replying on this, No, we are not having pulp3 version.
please find the image below :

image

Please do suggest next steps, Now, i am able to sync the task and products are getting reflected in the webui,

FYI :

But unable to see those in the sync status to sync the Suse repositories.
Can you please let me know where should i find and sync the repositories from the Suse?
Thanks in advance.
Ganesh

Ah ok, sorry.

If you click on Select products you should see the list of available SUSE-products.
You then have to select the products and hit the submit button at the bottom of the page.

This should create Products and repositories on Contents->Products page.
Does this work or do you have a problem on the SUSE Subscriptions-page where the available SUSE-SCC-Products are synchronized.

I am afraid the naming is a little bit confusing here, because synchronizing and products on the SUSE Subscriptions-page are different from synchronizing of (Katello-)products on the Content->Products page.

Hi,
No those are not getting showed under, content-product >

I have tried looking it under - Content-> Sync status and Content -> Product both but no luck.

The same has been performed earlier at that time under the sync status the Suse products got list ( Default Org) however, i have tried syncing - suse subscription under Ansys Org.
So i had reverted the snapshot and again followed all the process but this time we are not able to see the Suse products in both Organizations.

OK but have you already selected any products on the SUSE-Subscriptions-page?
After clicking on Select products:
SUSESubscriptionsSelectProducts

This will create a Subscribe SCC Product task, which creates the products and repositories in Content->Products:

1 Like

Yeah thanks works thanks.

1 Like

Great, glad I could help :slight_smile:

2 Likes

Hello,

Thanks a lot for your help.
Appreciated :blush:

Regards,

Ganesh Patil / System ADministrator
ANSYS INDIA
ganesh.patil@ansys.commailto:ganesh.patil@ansys.com
www.ansys.comhttp://www.ansys.com/