Synchronize repository 'Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server' HTTP status code: 502


i want to sync the ‘Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server’ and on first sync i get following error message after 20 minutes of sync:

Error message: the server returns an error
HTTP status code: 502
Response headers: {“date”=>“Thu, 29 Jul 2021 06:41:48 GMT”, “server”=>“Apache”, “content-length”=>“445”, “connection”=>“close”, “content-type”=>“text/html; charset=iso-8859-1”}
Response body:

502 Proxy Error

Proxy Error

The proxy server received an invalid

response from an upstream server.

The proxy server could not handle the request GET /pulp/api/v3/content/rpm/packages/.

Reason: Error reading from remote server

After the sync 0 packages are in the repo and when i make a normal sync after that the sync is succes but no packages are in the repo.

I have tried to disable and enable the repo but the error remains.

Foreman version: 2.4.1
Katello version:
Proxy version:

Prior to pulp 3.14 pulp would not retry downloads, which means if any network issue occurs pulp fails the sync. I believe that is what is happening with your syncs. You can try re-syncing until it hopefully completes.

This is fixed as part of pulp 3.14 via: Story #8881: As a user, Pulp will retry downloads by default 3 times and I can configure this value on my Remote - Pulp

Which is now included via Katello 4.1.

Thanks for your quick answer.
That means I should upgrade the Katello to 4.1 and the Foreman to 2.5.
Then it should work.
I’ll try it and then let you know if it worked