Traces want reboot after package update


I have just installed some updates (nagios-plugins*) on some CentOS 8 Hosts through Katello Content Host Package page using the remote execution plugin. Updates are installed successfully, however all updated Hosts are now marked red with status “Error” and “Trace: Reboot required”. When I check the Traces tab for those hosts more than 30 applications on each requiring attention are listed (basically everything). The nagios plugins should not cause that.

Now if I run katello-tracer-upload on each of those host the error disappears, traces shows nothing anymore. Everything is as it’s supposed to be.

It seems to affect only CentOS 8 hosts. Whenever I install, update or remove a package it ends up in this state. Each time a katello-tracer-upload fixes it again.

Expected outcome:
Traces should be correct like after the katello-tracer-upload run.

Foreman and Proxy versions:
Foreman 2.0.1

Foreman and Proxy plugin versions:
Katello (including patches from this thread)

Distribution and version:
CentOS 7.8.2003

Actually it also happens with any install, update, remove on the system itself. If I install or remove a package using dnf install/remove it’s out of sync afterwards. After I run katello-tracer-upload it’s good again. So I guess it must be an issue with the plugin?

But it says it uploads something:

# dnf -y remove sysstat
Installed products updated.
Uploading Tracer Profile

Hey @gvde,

Katello 3.16 contains a lot of improvements around the Tracer feature including the accuracy of reporting especially with EL8 content hosts. I recommend upgrading the 3.16 when it is GA and make sure to update the katello-host-tools-tracer & tracer packages on your systems at that time. I expect the behavior you reported to improve.

Thanks. Does that mean I can also update the python3-tracer and tracer-common packages to the latest 0.7.3-2 from EPEL? Currently, even the 2.1 client repository contains tracer-common version 0.7.1-2 and I am wondering why it contains an older version than the one in EPEL…

I think it’s because we don’t want to make users enable EPEL if they don’t want to, so we ship the package in our repos.

0.7.3 is very new and Katello 3.16 will have 0.7.2. I suppose you could update to tracer from EPEL, but that won’t get you all of the improvements that I’m referring to in Katello 3.16

Well, that doesn’t work at the moment as there are a few more packages from EPEL required to install the client which are not part of the client repository.

I checked on CentOS 7. katello-host-tools-tracer requires python2-tracer which requires
and by python-beautifulsoup4 requires python-html5lib

Those 5 rpms are all EPEL 7.