Ubuntu 20.04 autoinstall not getting user-data file

Problem: I am trying to PXE install Ubuntu 20.04 to a VM on VMWare. I have the install media configured on a separate httpd server and at the point where I can get the VM to provision and boot off of the install media. However, it seems that the user-data never gets pulled in to Auto Install. The VM boots to the first input screen requesting a Language selection.

I have the ISO available via HTTP. I am using the following Provisioning Templates:
Partion Table → Preseed default autoinstall
Host initial configuration template → Linux host_init_config default
PXELinux Template → Preseed default PXELinux Autoinstall
User data template → Preseed Autoinstall cloud-init user data

They are all stock templates and have not been altered.

Expected outcome:
Autoinstall of Ubuntu 20.04
Foreman and Proxy versions:
Foreman 3.5.1 & Proxy Single Host
Foreman and Proxy plugin versions:

Name Version
foreman-tasks 7.1.1
foreman_ansible 10.3.0
foreman_dhcp_browser 0.0.8
foreman_discovery 22.0.2
foreman_fog_proxmox 0.14.0
foreman_kubevirt 0.1.9
foreman_openscap 5.2.2
foreman_puppet 5.0.0
foreman_remote_execution 8.2.0
foreman_snapshot_management 2.0.2
foreman_statistics 2.0.1
foreman_templates 9.3.0

Distribution and version:
RHEL 8.6 Host
Other relevant data:
I have checked the httpd/foreman_access.log and do not see any requests for /userdata/user-data from the VM. However when I render the PXELinux template is looks as I think it should:

# This file was deployed via 'Preseed default PXELinux Autoinstall' template
# Supported host/hostgroup parameters:
# blacklist = module1, module2
#   Blacklisted kernel modules
# lang = en_US
#   System locale
# Foreman will not download the kernel/initramdisk to PXE automatically. Please follow
# the official Ubuntu documentation and extract the files from the LiveCD (DVD) manually
# and optionally update the KERNEL and INITRD lines in this template.
DEFAULT linux cloud-init autoinstall
LABEL linux cloud-init autoinstall
    KERNEL boot/ubuntu-20-04-mKeBtkiN3zG9-vmlinuz
    INITRD boot/ubuntu-20-04-mKeBtkiN3zG9-initrd
    APPEND url=http://web02.domain.local:80/pub/installation_media/ubuntu/20.04-x86_64.iso autoinstall ds=nocloud-net;s=http://foreman01.domain.local/userdata/ root=/dev/ram0 ramdisk_size=1500000 fsck.mode=skip BOOTIF=01-00-50-56-a9-68-2e ip=dhcp locale=en_US

I keep thinking I am missing something simple on this set up - but have not yet been able to locate it.


can you check in /var/log/foreman-proxy/proxy.log for the request of the user-data?
I had cases of setups, which were updated from older versions, where in the configuration the “trusted_proxies” setting was empty because it did not exist, when they installed the foreman/katello. In this case you should get errors in the proxy.log.

If this is the case check your foreman/katello-answers.yaml under /etc/foreman-installer/scenarios.d/ and check if the trusted_proxies setting contains your server.

Thanks - That seems to have moved me past that issue. Got user-data coming in now.

On to some template tweaks - Thanks again.