Ubuntu 22.04: Kernel failed invalid argument

Provisioning of Ubuntu 22.04.4 ends in “Booting kernel failed: Invalid argument”
Did find this topic, but haven’t found any solution

Expected outcome:
Started install after kernel boot

Foreman and Proxy versions:
Foreman 3.10 with Katello 4.12
Foreman and Proxy plugin versions:

Distribution and version:


Installation media:
Setup according to Provisioning hosts just with Ubuntu 22.04.4 instead of 22.04.03.

Name: Ubuntu Local
Path: http://foreman-test.mydomain.com/pub/installation_media/ubuntu/$version-$arch
Operating System Family: Debian

I am able to reach http://foreman-test.mydomain.com/pub via the browser

Operating System Setup:
Name: Ubuntu
Major version: 22.04
Family: Debian
Release name: jammy
Architecture: x86_64

Partition Table: Preseed default autoinstall
Installation Media: Ubuntu Local


  • Host initial configuration template: Linux host_init_config default
  • PXELinux template: Preseed default PXELinux Autoinstall
  • User data template: Preseed Autoinstall cloud-init user data

Operating system setup on host:
Architecture: x86_64
Operating system: Ubuntu 22.04
Media: Ubuntu Local
Partition Table: Preseed default autoinstall
PXE loader: PXELinux BIOS

Can you verify that vmlinuz and initrd were successfully downloaded? If the mirror is not correctly delivering the data, the files are likely empty or contain just a html error page instead of the real context.

It does seem like there was a mistake in the path for the Installation media, as foreman had been using the path for 22.04-amd64 instead of 22.04-x86_64 according to httpd logs.

“GET /pub/installation_media/ubuntu/22.04-amd64/casper/vmlinuz HTTP/1.1” 404 196 “-” “curl/7.61.1”

I changed the path to http://foreman-test.mydomain.com/pub/installation_media/ubuntu/$version so it is independent of $arch, but it dosen’t seem to have fixed it.

Is there anything that caches the initrd and vmlinuz files? We don’t see any successfull http queries from foreman either

The files get downloaded to the tftp boot directory, not sure about the path in Ubuntu, but I think it is somewhere in /srv/. You need to delete the downloaded files and then when enabling a build with the OS they will get downloaded again, so I typically cancel build and then click on build again to do so.

That seems to have fixed it. Thanks @Dirk!
For others, the files lived in /var/lib/tftboot/boot/