Ubuntu ignores pulp repo

I’ve succefully added Ubuntus repos to my katello instance. I’ve added the packages from aptix (thanks to them!) and succefully subscribed a 20.04 instance.

However ‘apt update’ fails with 404 errors and I see all the repo are being ignored :

Ign:11 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Backports default InRelease
Ign:12 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Updates default InRelease
Ign:13 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Main default InRelease
Ign:14 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Security focal Release
Ign:15 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Backports default Release
Ign:16 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Updates default Release
Ign:17 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Main default Release
Ign:18 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Security focal/all amd64 Packages
Ign:19 katello://katello.address/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Security focal/all all Packages

Expected outcome:

The subscribed node should be able to list and use the katello repositories/

Foreman and Proxy versions:


Foreman and Proxy plugin versions:


Distribution and version:

CentOS 7 for the katello server, Ubuntu 20.04 for the subscribed node.

Hi, I suppose you mean the subscription-manager from ATIX that you installed. So, you created repositories, synced them, created a content view for your Ubuntu repositories, published it and registered your host with an activation key pointing to that content view. The content view offers all required subscriptions and your host is attached to this content view. Am I right so far?

In that case you could try if you can reach the repository ‘manually’ using wget. You can extract the relevant data from your sources list:

grep URIs /etc/apt/sources.list.d/rhsm.sources | sed 's:\([0-9]*\)@:--certificate=/etc/pki/entitlement/\1.pem --private-key=/etc/pki/entitlement/\1-key.pem :;s|URIs: katello://|wget --ca-certificate=/etc/rhsm/ca/katello-server-ca.pem|'

Any error here could give you a hint about what is not working correctly in your setup.

Hi Adelglise,
Could you please tell me how you set up the repo for Ubuntu ? I created a topic a few days ago " Problems creating a repo for an ubuntu 20.04 host" explaining my issue. It should be pretty simple, yet I must be doing something wrong. I would greatly appreciate it.


Hi, thanks for your help.

Indeed, you are right.

It seems that there where a network issue, and the foreman/katello server wasn’t reachable on port 80. I’ve fixed it and I can curl the repo address. However the problem is the same:

E: Failed to fetch katello://katello/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Security/dists/default/all/binary-amd64/Packages  404  Not Found
E: Failed to fetch katello://katello/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Updates/dists/default/all/binary-amd64/Packages  404  Not Found
E: Failed to fetch katello://katello/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Backports/dists/default/all/binary-amd64/Packages  404  Not Found
E: Failed to fetch katello://katello/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Main/dists/default/all/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

I’ve tried to reregister the node, but it’s still failing at fetching the repo content. I’ve double checked my content view and my activation key and everything seems ok.

I used this command to register the node subscription-manager register --org="redacted" --activationkey="rkg-rc-ubuntu" --force.

Okay, the error is indeed different. In the first case you couldn’t access any repository at all, now there is only 4 index file that your host cannot read. Probably it’s looking for architectures that are not there.

But you should be able by now to install packages from your foreman. Can you try that?

I am not sure it is just that. It is trying to download package indecies for Ubuntu_20_04_Main/dists/default/all/binary-amd64/Packages which tells me that this index is referenced from the Release/InRelease file, but then can’t be downloaded. (Is not even there as an empty index). I don’t think that should be possible if everything went right with the sync and the publish… @adeleglise Can you navigate to this missing index file in a browser? (Starting from for example katello://katello/pulp/deb/redacted/rc/rkg-ubuntu/custom/Ubuntu_20_04/Ubuntu_20_04_Main/dists/default/)

1 Like