Unable to add Repos at all


This is on a fresh install of Katello + Foreman, when using the Web GUI and adding a repo I get the error " Validation failed: Content type is not enabled. must be one of the following:"

I then tried to use the CLI to create a repo and received the same error. I tried to then enable a specific repo set and got back the error that Repository sets are not available for custom products. This is my first time using Foreman so just wandering if there’s a setting I’ve missed or something I haven’t installed. Thanks
Expected outcome:
Lists of repository’s to spring out of a dropdown menu

Foreman and Proxy plugin versions:
Foreman 3.1
Katello 4.2

Hey @harrytgsa
Does it sound like this:

It looks like i’m having that issue but I made a mistake and I’m actually using version 4.3 and presumably that bug would’ve been fixed in the newer version?

Are you on the nightly version?
Katello 4.3 hasn’t been released yet.

Hello… Is there any fix for this?
I have freshly installed Foreman 3.4 and Katello 4.6 and facing same issue.

Appreciate your help!