Unable to create a DEB repository

**Problem:deb is not available for repository type

**Expected outcome:deb option unavailable to create a Ubuntu repository

**Foreman and Proxy versions:3.3

**Foreman and Proxy plugin versions:3.3

**Distribution and version:RockyLinux 8.6

Other relevant data:
Katello 4.5

The only options available are for Yum Repositories and Container Images

With a fresh install of Foreman 3.3 and Katello 4.5 on RockyLinux 8.6 we do not have a repository type option for creating DEB to use for Ubuntu systems. We verified that --foreman-proxy-content-deb is set to true but cannot determine why deb is not available. Are we missing a plugin, is an install package missing to provide apt-get or an option not set that was overlooked?
We are able to setup and configure RockyLinux and CentOS repositories (understandable due to them also being YUM based) with no issues and updated clients against them but we are having the darnedest time setting up a Ubuntu repository on this system.

We also tried another fresh install with Foreman 3.2 and Katello 4.4 which works well except is still missing DEB support which makes us believe we missed something in the setup.
Used this setup guide to install Foreman 3.3 and Katello 4.5 with no issues

We have not tried using a CentOS host yet and are trying to avoid if at all possible.

I am not aware of any special setup steps for enabling deb/APT content on new Katello installations.

I am leaving this comment in the hope of learning the answer. :confused:

There is no need to install any additional plugins or anything, Debian support is present on a fresh installation.

How do you try to create a Debian repository? Content → Products → select or create a product → New Repository? This gives the following screen here and I can create a deb type repo just fine:

1 Like

Will leave this here for @atix to reply, since deb is their area of expertise. We only support RPM

Thanks @evgeni but I do not have those options which is why I’m confused with this.

Content → Products
gives me this

where I am able to go into “Repo Discovery” to setup a YUM repository but do not have a DEB option there

Under Create Product there is no option for Type and I do not see the tabs as on your screenshot

This is on Foreman 3.3 with Katello 4.5 and I have the exact same screens with Foreman 3.2 and Katello 4.4
Is it a version thing? Should I try with 3.1?

The missing options and no tabs make me think I’m missing something as the YUM repos work how I expect but the difference I see from your description makes me wonder if I missed something in the setup.

Thanks for taking a look, hopefully we can figure this out

Don’t use repo discovery, I have no idea if that works for Debian.

Click “Create Product”, call it Debian or anything. Then click that product in the view, and then click “New Repository” in the new page.

Ah got it, that is where it was hiding!

Looks like that has it figured out for me now, I’ll let you know if I run into anything else on this but that was exactly what I needed, thank you!

1 Like