Unable to import Ansible roles, with status code 500

Problem: Unable to import Ansible roles

Expected outcome: To be able to import roles

Foreman and Proxy versions: 3.1

Foreman and Proxy plugin versions: 3.1(I assume?)

Distribution and version: Alma Linux 8.5, although I’ve tried in Ubuntu Server 20.04 with the same results
Other relevant data:

After dropping my Ansible roles over to /etc/ansible/roles/, Foreman detects it being there, but when I go and hit submit I get the following error:
Failed to import roles and variables Error: Request failed with status code 500
On later attempts I also tried giving the entire role 777 just for giggles and same outcome.

Oh the logs on /var/log/foreman/production.log(already with debug logging as suggested in the troubleshooting doc) I don’t see much either, just the following:

2021-12-15T14:48:21 [I|app|cd088555]   Rendering common/500.html.erb
2021-12-15T14:48:21 [I|app|cd088555]   Rendered common/500.html.erb (Duration: 2.7ms | Allocations: 1860)
2021-12-15T14:48:21 [I|app|cd088555] Completed 500 Internal Server Error in 18ms (Views: 5.5ms | ActiveRecord: 2.0ms | Allocations: 6633)

On /var/log/foreman-proxy/proxy.log I see nothing that could connect to this error.

This is a Foreman installation on a clean machine, nothing additional other than epel and vim.

Am I missing something additional step in the installation? Is there some additional port that is needed to be open? I’m at lost here, so any guidance is appreciated.

Hello all again,

As it turns out, this is an issue on 3.1 and 3.0, as I’ve managed to import Ansible roles just fine on the version 2.5.
Later through the day today I’ll file a bug report and steps to reproduce.

Regardless, thank you for your time.

With kind regards,